Anki Forums

Anki Desktop for Mac crashes when pressing command+c

I just want to copy things and every time I press command+c like normal the app crashes and I lose the content I haven’t synced :’)

My command+c works normally literally everywhere else so isn’t a global issue with my computer. I had no issues with it on Anki until I updated to version 2.1.42 earlier today, and is super annoying. It first happened when I was making image occlusion cards and then I tried it in various areas of the app and it happened even when I was just on the homepage looking at my decks

What version of MacOSX? Did you disable all extensions to isolate possible problem cases?

I am on macOS Big Sur 11.2.3, and I did disable all add ons and the problem still occurred after restarting post disabling

I can’t seem to reproduce this. What about other apps running on your machine, such as utilities that monitor the clipboard or modify your keyboard?

I have done it with no other programs open on my machine, and it doesn’t happen in any other apps either once I do open them.

It this happening with any text copied, or specific one (like UTF-8 extended range)? Does it happen with a simple deck with a single simple text entry card? Need more info what is exactly copied to clipboard.

1 Like

I’ve been having the exact same issue for a couple of months, but it’s with cmd+z. The shortcut works everywhere else and it occurs with all add ons disable and nothing running in the background. I’ve tried reverting back to older anki versions without success. I’d love if someone could figure this bug out

I’m also on macOS Big Sur 11.2.3…maybe that’s the common denominator

@marleyeasterbrook hey I don’t know if you’re having the problem still, but I fixed it by uninstalling all anki files and reverting to a previous version. Make sure you select “downgrade & quit” in the anki profile section before deleting. I used the following video to scrub my mac free from all anki files: How to Uninstall Anki for Mac? - YouTube. Good luck, my friend

I managed to solve this issue using the Customize Keyboard Shortcuts addon and setting a random shortcut to be Command+C.
Thus, I changed the "main debug":"Ctrl+:" line to "main debug": "Ctrl+C" from the addon’s settings.

I read that the issue will be solved in 2.1.45, but for now, this seems to do the trick :).