[Anki 23.12.1] Small bug: Global setting "Limits start from top 🌐" prevents increasing amount of new cards via custom study

You can reproduce the issue with this collection:

  1. Study all the new cards in this deck.
  2. After finishing all new cards, click on the deck > Custom Study > Increase today’s new card limit
  3. Even though there are more new cards available, Anki always says: “Congratulations! You have finished this deck for now.” Only disabling the “Limits start from top :globe_with_meridians:” setting fixes this and allows you to increase the limit.

Tagging @Rumo because he is probably familiar with this part of the codebase. :pray:

Custom study increases the limits for the deck you have active. If it’s a parent deck’s limit that is preventing cards from being shown, you need to use custom study on that deck instead.

If my memory serves me correctly, Anki used to automatically increase limits for the parents as well, but this could be surprising at times, and I think it was Rumo that argued it would be better to only adjust the deck the user has selected.

1 Like

Ah, I see. Since suggesting users enable the “limits start from top” setting a few days ago I already received 2 emails from people struggling with this.

I’d say that the previous way was more intuitive because right now the user isn’t even told why taking the same action as before didn’t lead to the desired outcome. It simply doesn’t work anymore.

Also, let’s say if you’re studying a nested child deck with 5 parent-decks, would the user have to increase the limit for each parent deck individually to be able to study more cards in the sub deck? That would be quite inconvenient, even 2 levels deep. It would also make the new global setting somewhat unusable for many people who need it as they can’t easily increase the amount of cards they want to study (just today) anymore.

Quite possible that it was me, but then it probably was in the context of adding parent limits to V3 in the first place? I didn’t consider custom studies when adding the “Limits start from top” option.
With this setting enabled, it seems reasonable to increase the parents’ limits as well.


I’ve logged this on Increase parent limits in custom study when 'limits start from top' is enabled · Issue #2965 · ankitects/anki · GitHub

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.