Anki 2.1.50 Beta 1 & 2

Ah, OK, Ctrl+Alt+i works, but the “More” menus shows this:


Thanks for the report. There’s a few issues with Mathjax still, and I’ll include this in the list. I’ll hopefully get them out before the next beta.

1 Like

This was likely caused by the toolkit update, since we haven’t changed the scaling factor ourselves. I made a PR.

It should be better on the next Beta release :slight_smile:


I like the idea, but only a few windows have a menubar. If we only added an entry to the main window, users might infer that other windows couldn’t be opened in fullscreen.
I would rather rely on inclined users trying their OS fullscreen shortcut and keep things simple.

1 Like

Loading images is sometimes much slower than usual. I’ll try to find some pattern and elaborate with more detail if I can.

Also, just after trying a card with mp3 embedded, I’ve received the “mpv not installed” message. I’ve never had that problem before, and simply restarting the program solved the problem. I’ve tried to replicate the problem, with no luck, but will keep an eye.

The layout is already flipped for RTL languages as far as I know, but aligning the contents of fields to the right automatically may not be desirable as RTL users don’t necessarily write all their cards in RTL languages. There is already an option to configure RTL direction under the Fields button.

about the recent conversion from camelCase to PEP8 compliant function and variable names (lowercase separated by underscores): I suggest to keep one exception in the long run, i.e. pointVersion besides point_version.

Otherwise - at least as far as I see - all add-ons that have one code base for all supported anki versions would have to work with try-except statements to find the proper point version which should be a lot of work among the many add-ons compared to just one line in anki itself?

Previously the window was aligned to the right but now the edit bar and field title and tags are aligned to the left unlike before.
And it has nothing to do with the content of the field.
By the way, the content of the field is aligned to the left in many cases even though in the actual back it is aligned to the right.
I’m trying to upload a picture but an error keeps popping up.

1 Like

You’re right. I remember testing with the development code and seeing that the editor is flipped, but that was actually a side effect of the following change, which is not included in any beta yet:

The editor will look like this in RTL languages after that change (as in the current stable version):


Very nice!
It remains only to fix the problems below:

“Another fix: On the Deck Options screen, In “The order of placement of new Cards”, the menu opening image appears on the right and not on the left”

“By the way, the content of the field is aligned to the left in many cases even though in the actual back it is aligned to the right.”

If you mean the arrows of the selector menus, then the above change linked above is meant specifically to solve this.

If you mean that the back field is aligned to the right when reviewing, this is because the card appearance when reviewing is also affected by the content of your templates (HTML code, CSS stylings). See Styling & HTML - Anki Manual


I want the field to appear during editing as in the review as defined in the template.
In some of my cards it’s like that and in some it’s not. I don’t know why.
Thanks for all the help and investment!

Does it happen on both Qt builds? Is it related to the size of the images?

Your card template controls how the card appears during review. The Field options control how the fields appear when editing.

1 Like

The main menu is missing in QT5 version, both in light and dark modes:


W10, no addons.

Qt5 is much faster and yes, the problem get worst with bigger images.

1 Like

When starting Anki (Qt6) in full screen mode (Windows version), the main menu and the deck options icon do not respond.

To reproduce:

Start Anki > Press F11 > File > Exit
Start Anki Again > Click on the main menu (File / Edit / Etc) / deck options icon > No response.

Start Anki > Press F11 > File > Swicht profile > Open
Click on the main menu (File / Edit / Etc) / deck options icon > No response.

The Qt5 version seems to work properly.

I can’t reproduce what you describe, but I’m experiencing a different bug with both Qt5 and Qt6 (also Win10). Maybe it has the same cause?
Reopening a window that’s been closed in fullscreen leads to an inconsistent state. The window is borderless, but underneath the taskbar and doesn’t cover the whole screen.

I noticed that when I use Anki Qt6 in full screen mode and I sync then the main screen refreshes in a weird way

I’m also experiencing some screen blinking after starting Anki (Qt6) in full screen mode, but the window covers the whole screen inall cases. The problems described in my previous posts are 100% reproducible in my system, though.

1 Like

I’ll look into it, but maybe the only solution is to never start in fullscreen, requirung the user to call it manually each time.
Fullscreen doesn’t seem to be a trivial matter and I wonder if we’ll hear about issues on more platforms…