Anki 2.1.40 is broken after update from 2.1.35


Anki 2.1.40 doesn’t update from 2.1.35 properly.

I tried:

  1. To install Anki as new (remove the old version before).
  2. To do Export/Import base.
  3. To do “Check Database”.
  4. To do “Check Media”.
  5. To do “Empty Cards”.

Anki shows me the error when I start learning the cards after first start Anki:


  1. Start Anki.
  2. Choose Deck.
  3. Start Learning.
  4. ERROR.
  5. Back to main decks.
  6. Choose Deck.
  7. Start Learning.
  8. No error.

If I restart Anki then to go to step 1.

I don’t use addons at all, only standard install Anki. I use media, only images.



An error occurred. Please use Tools > Check Database to see if that fixes the problem.

If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.

Anki 2.1.40 (cf446733) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2

Platform: Windows 10

Flags: frz=True ao=False sv=2

Add-ons, last update check: 2021-02-10 14:59:34

Caught exception:

Traceback (most recent call last):

File “aqt\”, line 87, in _on_closures_pending
File “aqt\”, line 59, in
File “aqt\”, line 279, in
File “aqt\”, line 565, in _on_done
File “concurrent\”, line 432, in result
File “concurrent\”, line 388, in __get_result
File “concurrent\futures\”, line 57, in run
File “aqt\”, line 279, in
File “aqt\”, line 562, in _play
File “asyncio\”, line 44, in run
File “asyncio\”, line 616, in run_until_complete
File “aqt\”, line 589, in speakText

Please fix it.

I come back to v. …35.

…and I use filtered decks and Windows voices.

Are you using text to speech?

The last person who reported that error said it turned out to be caused by the language they had selected going missing after a Windows update - I suggest you check whether the language is available. I’ll make a note to make Anki show a better message in this case.

1 Like

Yes, I write about this:

Does 2.1.35 version have any attention about this? Just, in 35 all ok, no errors.

Or in 2.1.35 version this exception doesn’t check this error?

I checked languages.
Really, one of the two computers is missing some languages, but another computer have all languages.

The error was at two computers.

v. …35 is all ok on two computers.

Don’t know Microsoft windows updates, assumes this does not happen often concerning removing languages from an upgrade, it should be the opposite, more languages are added, so a real error dialog showing this is a lot of work for a seldom-happening thing.

If I was a QA lead in a triage-meeting, I would flag this as ‘future- nice fix’ but not important…

I use 3 languages… in future, I will want to use more languages.
If this information is helpful.

@Kirill recent Anki versions use Microsoft’s newer TTS libraries, which support more voices. If the voices work in .35 but not .40, and you’re sure you have the voices installed, that is strange. Does restarting your computer help? If not, you could try the following in the debug console to try using the older libraries instead.

from aqt.tts import WindowsRTTTSFilePlayer as P
P.default_rank = -2

@khs I agree re the earlier report, but in this case it appears the voices are available but not working

@dae , is there a portative version of Anki? I don’t want to remove worked version (.35). Or where can I read how I can run Anki from source?

Portative version is better…

@Kirill See here for documentation on running Anki from a thumb drive.

1 Like

Thanks a lot, but to use your case I need to install .40 before. This doesn’t suit me…
As I write before I don’t want to install .40 'cause I don’t sure it works properly in my current OS. I necessarily reinstall OS, but not today.
I often use Anki and I need properly worked Anki.
For check pointed case by @dae I need a portative version (without install) or run from source.

As I see the times of buggy Windows are returning. :slight_smile:

Thanks a lot, but to use your case I need to install .40 before.

This is not the case. You can use this method with your version as well.

If you are happy with .35, you can just remain on that for now. I don’t need you to test the code above, I was providing it to you in case you wanted to continue using .40.

Unfortunately, I will not test it for you, I will want to test Anki .40 for me on my OS with your recommendations.

And I asked there is a portative version of Anki .40 'cause I don’t want every time install, uninstall .40 and install .35 again if .40 will not be worked properly on mine buggy OS. Or there is a manual how to run Anki .40 from source code (what libraries, etc).

Ok. Please tell to me steps how it can help me. Maybe, I am confused.

One thing.
I installed .35 already.