Anki Forums

Cannot create Anki Deck Packages after recent update 2.1.49

The software will not allow me to export Anki Deck Package files after I upgraded to the 2.1.49 version. There are automatic Anki2 files being created in the folder I store my deck packages that I do not want(?) and the normal anki deck files create an error message. I use that export function to share the decks I create with my fellow students. Please advise how to either go back to the previous version of Anki, which worked fine for what I needed, or fix this issue. Thank you.

Error
An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.49 (dc80804a) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2021-11-23 18:43:50

Caught exception:
Traceback (most recent call last):
File “aqt\taskman.py”, line 101, in _on_closures_pending
File “aqt\taskman.py”, line 71, in
File “aqt\exporting.py”, line 173, in on_done
File “concurrent\futures_base.py”, line 432, in result
File “concurrent\futures_base.py”, line 388, in _get_result
File “concurrent\futures\thread.py”, line 57, in run
File “aqt\exporting.py”, line 167, in do_export
File “anki\exporting.py”, line 342, in exportInto
File “anki\exporting.py”, line 350, in doExport
File “anki\exporting.py”, line 253, in exportInto
File “anki\models.py”, line 539, in update
File “anki_backend\generated.py”, line 450, in add_or_update_notetype
File "anki_backend_init
.py", line 131, in _run_command
anki.errors.TemplateError: Card template ⁨2⁩ in notetype ‘⁨Basic (and reversed card)⁩’ has a problem.
The front side is identical to card template ⁨1⁩.

Check that there are no duplicate templates in that notetype.

Should it be set to Card 1 or nothing? It is currently set to Card 2. I have never had this issue before and I do not build the decks any differently than before the upgrade.

Thank you for your help.

First, make a manual backup of your collection, just in case.

Then, go to Browser > Edit > Card, and make sure that the two templates are different:

1 Like

Ok! I had to “flip” the Card 2 option and now it works. Thank you so much for helping out.

1 Like