Amboss addon issue

Had the add on working just fine, added all the anking add one and suddenly the amboss add on became buggy. I tried dis-enabling every other add on but it’s the amboss add on in particular that is causing the issues. This is the error message I keep getting. I even tried reinstalling anki entirely


An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.

If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.

When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.

Debug info:

Anki 2.1.30 (06a69c25) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1

Platform: Windows 10

Flags: frz=True ao=True sv=1

Add-ons, last update check: 2020-08-17 17:07:29

Caught exception:

Traceback (most recent call last):

File “C:\Users\mgehr\AppData\Roaming\Anki2\addons21\0amboss_addon\”, line 96, in _route

return AnkiWebPage.acceptNavigationRequest(

File “aqt\”, line 104, in acceptNavigationRequest

AttributeError: type object ‘AnkiWebPage’ has no attribute ‘open_links_externally’

Maybe try to update the add-on -

I have the same problem on Mac. The amboss add-on downloaded from its website cause crash