2.18.1 bug: The tag chooser writes tags with non-Latin chars garbled to db

The tag chooser writes tags with non-Latin chars garbled to db, e.g. German umlauts and emojis. Anybody know if there is an issue for that yet?

1 Like

Can you say more about which characters you’re talking about? And what “broken” means? (And also post what you get from Settings > About > Copy debug info.)

I just checked this with the non-Latin characters I use regularly (which include the equivalent of German umlaut-ed characters), and they show up fine for me. Of course non-Latin and non-ASCII aren’t the same thing, hence my questions above.

image

Debug info

AnkiDroid Version = 2.18.0 (464cf290cc77c3f2c562cb03b408b78a13be261b)

Backend Version = 0.1.38-anki24.04.1 (24.04.1 ccd9ca1a8309b80bcb50ddc5d99c7ce63440bce9)

Android Version = 9 (SDK 28)

ProductFlavor = play

Manufacturer = Amazon

Model = KFONWI

Hardware = mt8168

Webview User Agent = Mozilla/5.0 (Linux; Android 9; KFONWI Build/PS7321; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/94.0.4606.71 Safari/537.36

ACRA UUID = 7d4c980a-f818-4cde-b15a-8821b44cf70e

FSRS Enabled = true

Crash Reports Enabled = true

1 Like

Thank you for answering. :slight_smile:

The bug is new in 2.18.1. You are on 2.18.0, which works fine.

It is even worse than I thought because when I edit tags, all tags are written broken to the changed notes!

AnkiDroid Version = 2.18.1 (5d13819ba811c6baea34dc747fce0568c755f31a)

Backend Version = 0.1.38-anki24.04.1 (24.04.1 ccd9ca1a8309b80bcb50ddc5d99c7ce63440bce9)

Android Version = 13 (SDK 33)

ProductFlavor = full

Manufacturer = Google

Model = Pixel 4a

Hardware = sunfish

Webview User Agent = Mozilla/5.0 (Linux; Android 13; Pixel 4a Build/TQ3A.230805.001.S1; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/124.0.6367.179 Mobile Safari/537.36

ACRA UUID = e48147db-e59c-4853-929c-905d382dd7e3

FSRS Enabled = true

Crash Reports Enabled = true

In the pics it’s only Emojis, but also happens with German umlauts.

2.18.0:

2.18.1:

1 Like

I’m glad you clarified the version you were talking about. That will help the devs know where to focus their efforts.

1 Like

Think this is the issue: [BUG]: 2.18.1 version, add card page, click Tags, error to goto home page · Issue #16476 · ankidroid/Anki-Android · GitHub

2 Likes

This is happening also in 2.19alpha2. I thought it was me who imported some deck with not supported characters.

1 Like