Unknown cause of corrupt file, have followed prompts and still cannot see my anki cards. Error message below continues to appear. Please help!

Additionally, I have tried the shift key and restarting the app and it’s still not working.

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 6.3.1 PyQt 6.3.1
Platform: Mac 12.0.1
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2022-09-18 10:14:28

Traceback (most recent call last):
File “aqt.main”, line 574, in loadCollection
File “aqt.main”, line 673, in moveToState
File “aqt.main”, line 679, in _deckBrowserState
File “aqt.deckbrowser”, line 69, in show
File “aqt.deckbrowser”, line 143, in _renderPage
File “anki.scheduler.base”, line 58, in deck_due_tree
File “anki._backend.generated”, line 344, in deck_tree
File “anki._backend”, line 146, in _run_command
anki.errors.DBError: DbError { info: “InvalidType”, kind: Other }

When did it start? Installed any add-ons recently? Tried restoring from a backup made before the issue started? Restoring an Automatic Backup (Recovering from Data Loss) - Frequently Asked Questions