"Unexpected response code: 403" when pasting an image

I am getting this weird notification of unexpected response whenever I paste an image in a “Cloze” type card. The image end up appearing, but after I synch it is gone :frowning: Helpppp

MacOS V2.1.47

Screen Shot 2021-09-05 at 5.09.15 PM|664x304

If you’re copying the image from a website, you may have more luck cmd+clicking on it and choosing “copy image” instead of “copy image location”

Thanks a lot for the response. But I am already copying the image itself instead of the address, the same way I always did. I first got this warnings after updating. I tried to uninstall and reinstall but it did nothing. The image always shows up after the notification, but some of them go missing later on when I synch. Still, yesterday I replaced the missing images and got the same warning screen again, but the images are still available on my cards after the replacement, I just don’t know for how long.

Please confirm you can reproduce the issue with add-ons disabled:

https://faqs.ankiweb.net/when-problems-occur.html

If you can, would you be able to link to a webpage you’re copying from, and specify the steps I should take in order to trigger the issue?

Hi, thank you again for the availability. Yes, I’ve tried disabling the add-ons, checked my database, restarted everything and the problem remains, unfortunately.

I am sending you a link from an image which shows the same problem. What I did was:

Copy Image → Open the Cloze card type → cmd+v at “back extra” (I’ve tried clicking paste as well, still the same) → Error message → the image appears anyhow, but some go missing after a while.

Link: https://s3.us-west-2.amazonaws.com/secure.notion-static.com/90cc6ae3-1a44-4709-ad3b-16cb06eac8c9/Screen_Shot_2021-08-24_at_10.52.27_AM.png?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAT73L2G45O3KS52Y5%2F20210908%2Fus-west-2%2Fs3%2Faws4_request&X-Amz-Date=20210908T125806Z&X-Amz-Expires=86400&X-Amz-Signature=d305eabd0aaa6cb5cd2b32567ba957b82e9a6a2a92db4f61f9bb4e786674ead3&X-Amz-SignedHeaders=host&response-content-disposition=filename%20%3D"Screen%20Shot%202021-08-24%20at%2010.52.27%20AM.png"

As you can see this link comes form my Notion page. I just tried some random dog image direct from google images and didn’t get the error message.

Link: https://www.guidedogs.org/wp-content/uploads/2019/11/website-donate-mobile.jpg

The thing is I never had this problem before even with images from my Notion page, just after the update. Do you think there is something related?

The images that I pasted and got the error message 2 days ago just went missing

Notion is likely giving out time-limited links to the images. The question is why you are getting them - if an image was in the clipboard, Anki should have put that image in your media folder instead of including a link. Even if it’s provided with a link, it should attempt to download the file so it doesn’t have to rely on a link.

Rather than providing a link to an image directly, can you provide a link to a page that has an image on it, so I can try to use ‘copy image’ myself? It may also be worth trying with a different browser to see if that makes a difference.