Unable to launch Anki Version 23.12.1 QT6

I’m on the latest version of Win 11 and I have updated to the latest version of Anki (23.12.1 QT6) so that I can use FSRS but since updating I can no longer launch Anki except by holding down shift. I receive the error code:

Error during startup: ⁨Traceback (most recent call last):
File “aqt.main”, line 200, in init
File “aqt.main”, line 249, in finish_ui_setup
File “decorator”, line 232, in fun
File “anki.hooks”, line 89, in decorator_wrapper
File “anki.hooks”, line 84, in repl
File “aqt.toolbar”, line 274, in draw
File “aqt.webview”, line 594, in stdHtml
TypeError: setHtml() takes 2 positional arguments but 3 were given

I’ve reinstalled it many times but nothing is helping.

Please help me fix this thank you very much!

If it works with a shift-start, that means its mostly likely an add-on that’s interferring – especially since you just updated. Did you check all of your add-ons to make sure they are compatible with the new version?

The fastest way to narrow down which is (or which are) causing the issue is in the Troubleshooting guide. Troubleshooting - Anki Manual

2 Likes

Thank you for your reply.

I had already tried updating all my add-ons but it still didn’t work (and also nothing on the troubleshooting guide worked) but just now I disabled all of them and then restarted Anki - and it worked!

“Updating” all of your add-ons only helps if there’s a new version of those add-ons that is compatible.

Disabling your add-ons is what I was talking about in the Troubleshooting guide – and apparently that worked.