Unable to Edit - FAILURE

Anki on my Mac closes every time I edit a card. Incredibly frustrating and loss of time. Do you know what’s going on? Here is the error report:

Process: Anki [3989]
Path: /Applications/Anki.app/Contents/MacOS/Anki
Identifier: net.ankiweb.dtop
Version: 2.1.26 (???)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Anki [3989]
User ID: 502

Date/Time: 2020-06-10 13:36:55.687 -0700
OS Version: Mac OS X 10.15.4 (19E287)
Report Version: 12
Bridge OS Version: 3.0 (14Y908)
Anonymous UUID: 8876C05B-DA5E-9771-3A2C-1DDE6AC2E2CD

Sleep/Wake UUID: F82CA3F5-A14F-430F-AAC4-415A1316876C

Time Awake Since Boot: 10000 seconds
Time Since Wake: 1100 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00003853e813c380
Exception Note: EXC_CORPSE_NOTIFY

VM Regions Near 0x3853e813c380:
VM_ALLOCATE 0000000140009000-0000000140209000 [ 2048K] rw-/rw- SM=PRV
–>
MALLOC_NANO 0000600000000000-0000600008000000 [128.0M] rw-/rwx SM=PRV

What actions are you taking in the editing screen? Does the issue occur if you download the -alternate version from Anki’s download site?

Just clicking edit then typing causes failure. Lets say I just type “the” and then I click Done and the software shuts off. What is the alternate version? I have the most recently updated version.

https://apps.ankiweb.net/

Unsure why this link was put. Still having the same issue.

That link is where you will find the alternate version as you asked where it was:

Also, if you are felling adventurous, you can try installing the latest beta (and alternate beta) versions from Intro & Downloads - Anki Betas

2 Likes

The alternate version worked. I dont think I’m brave enough to mess with the beta. Thank you!

1 Like

Started happening again. I do not understand. Same error message problem report from apple.

Do you have any addon installed? Please see When problems occur and Getting help

Are you sure you are not using the standard version again? You can try:

  1. drag the old Anki.app file to the trash
  2. install again the latest alternate Anki version from https://apps.ankiweb.net by opening the .dmg and dragging the icon to your Applications folder

If it still not working, you can try installing the latest beta (and alternate beta) version from https://betas.ankiweb.net/#/

Can you try running Anki from the command line to see if any warning or errors are output to the console?

Can you look into https://changes.ankiweb.net/#/known-issues and try changing a few things like: (one at a time)

  1. ANKI_NOHIGHDPI=1
  2. ANKI_WEBSCALE=1.1
  3. ANKI_WEBSCALE=1
  4. ANKI_WEBSCALE=0.9

Some Googling of the error message seems to indicate that it may be caused by another app you have running on your machine, like BetterTouchTool, Slate, or similar tools that hook into Apple’s accessibility infrastructure. Do you have any utilities running on your system to provide window snapping, shortcuts or similar?