Anki Forums

Problem with Quizlet to anki add on- mac book

Up until last week, my quizlet add on worked great. However now when I add a set from quizlet, it loads and says “completely converted x amount of cards” but when on the Deck page, it shows my quizlets with 0 cards and will not let me study them. In browse it says there are no cards, and im not sure why. Please let me know, thanks

If you have other add-on installed, maybe try this add-on, maybe in a new Anki profile (File - Switch Profile). If it still doesn’t work, let me know the Quizlet url.

https://ankiweb.net/shared/info/538351043

Maybe try a different Quizlet url, maybe this one, as it works for me.

https://quizlet.com/gb/288744791/french-numbers-1-100-diagram/

https://quizlet.com/484497432/antimicrobial-general-priniciples-flash-cards/
This is the link i am trying to use

It works fine for me. It says, “Success! Imported … (47 cards)”.

It doesn’t let me study your link either, strange

What do you see?

Once I use the add-on (Tools - Import from Quizlet), this is what I see.

изображение

The interface might be a bit different in old Anki versions but the message should be the same, “Success! Imported … (47 cards)”.

If it’s about new cards, please see,

https://faqs.ankiweb.net/anki-is-not-showing-me-all-my-cards.html#new-cards

The message is the same

Great! If you click on the deck and then go to the card browser, all the cards should be there.


Unfortunately it still says theres no cards in the deck, although it said they all were imported

Maybe this is a different deck. It should be "deck:Antimicrobial General Priniciples". Or maybe you set a parent deck as “abx 1” while using the add-on to import a Quizlet set. In this case, it’s strange that it’s empty.

Since it’s working fine for me, try again to use the add-on and import a Quizlet set, but in a new Anki profile, a new deck should appear on the main screen. If the card browser will still show 0 cards, maybe restart Anki while holding down the Shift key to temporarily turn off the add-ons.

Additionally, maybe search for some phrase from the set in the card browser, e.g. "when the presence of a microbe"

I tried searching for the phrase, i found the cards, however it is in my “hematology fundamentals of clin medicine” parent deck. Any ideas on how to move the cards in to the antibiotics deck?

Or, how to re-import them without them going to the wrong place

There’s a context menu to change the deck for selected cards.

изображение

Alternatively, use the add-on again, but leave the parent deck to be empty. The add-on will create new cards and put them in “Antimicrobial General Principles” deck.

Thank you, this works except if i want different topics (a seperate quizlet on antibiotics) into the same parent deck, it adds all my cards into one deck. Will i need to highlight and change the deck everytime i upload?

Changing the deck manually from the card browser or using a drag-and-drop from the main screen to move imported decks into the same parent deck will definitely work, but using the add-on with the parent deck set should work too.

I think my issue is with the add on, it wont add new cards to anything other than the first parent deck. So when i added a pulmonology deck, they all went to antibiotics

I don’t know how to reproduce the issue.

If I try in a new Anki profile to import one Quizlet set with the parent deck set to “something” and then import another Quizlet set with the parent deck set to “something else”, everything works for me. The first Quizlet set goes to something::<name of the set> and another Quizlet set goes to something else::<name of the set>.

If the add-on works in a new Anki profile, but doesn’t work with your main Anki profile, maybe check the “Deck Override” option in the “Basic Quizlet” note type (Tools > Manage Note Types > Basic Quizlet > Cards). It should be “off”.

1 Like

That worked, thank you for your patience!

1 Like