Anki Forums

Linux: Fatal Python Error

Hello! I don’t really know where to post this so I’m going to guess and put it here.

Yesterday something happened to my Anki program on Linux. I specifically use Pop!_OS and was running the Ubuntu version of Anki flawlessly. Now it just won’t boot up. I found the crash log and it says there was a “Fatal Python Error”. I made sure my python 3.8 thing was up to date. I also tried uninstalling/reinstalling multiple times. I also googled the issue and couldn’t find anything that useful. I would love to have my regular Anki back!

I appreciate any help or ideas!

Full Crash Log:

Fatal Python error: Segmentation fault

Thread 0x00007fddb1ffb700 (most recent call first):
File “/usr/lib/python3.8/threading.py”, line 302 in wait
File “/usr/lib/python3.8/threading.py”, line 558 in wait
File “/usr/share/anki/anki/sound.py”, line 193 in run
File “/usr/lib/python3.8/threading.py”, line 932 in _bootstrap_inner
File “/usr/lib/python3.8/threading.py”, line 890 in _bootstrap

Current thread 0x00007fde7a1a8740 (most recent call first):

I’m just a user.

I wonder which package you installed from where, from source?

Just to be sure: https://faqs.ankiweb.net/third-party-linux-packages-and-source-builds-are-not-supported.html

Do you still have this problem if you use the latest binary (2.1.35) from ankiweb without add-ons after restarting your computer? (see https://faqs.ankiweb.net/when-problems-occur.html)

1 Like

I do have the problem still, but I think I was looking at the wrong Crash Log. The first thing I tried was installing it from the most updated file instead of the repository. The error I see in the Terminal is “Bus error (core dumped)”.

I seem to have fixed it. I was triple checking that I hadn’t made some dumb error, and it started to work again. I have no idea what I did.

I guess I just made some kind of dumb error. Thanks for your input!