Issues with the add on symbols as you type

Ive only got only one add on downloaded so i can use mathematical symbols like pi and delta in my flashcards. Unfortunately neither of the two available versions work. the first one i downloaded didn’t work at all, then i found the fixed version of the add on and proceeded to download it. at first everything seemed fine but as i went to customise the symbols, it started showing me the error report you can see below. i deleted the add on, redownloaded it, restarted my laptop and the app, nothing worked. Added to that i cant even use common methods of typing the pi symbol like num lock and the different alt + key combinations. i reckon i really need the add on but nothing i tried has worked so far. Can anybody help? thanks in advance

Caught exception:
Traceback (most recent call last):
File “C:\Users\idadr\AppData\Roaming\Anki2\addons21\2088399109\”, line 286, in accept
File “C:\Users\idadr\AppData\Roaming\Anki2\addons21\2088399109\”, line 259, in _save
errors = self._sym_manager.update_and_save_symbol_list(
File “C:\Users\idadr\AppData\Roaming\Anki2\addons21\2088399109\”, line 142, in update_and_save_symbol_list
File “C:\Users\idadr\AppData\Roaming\Anki2\addons21\2088399109\”, line 256, in _save_to_db
AttributeError: ‘DBProxy’ object has no attribute ‘commit’

There’s no need for addons to do this, just use an inline mathjax block (press the fx button in the add window). Greek characters can then be entered like \pi or \delta, or entire equations using normal latex expressions.

This version (released by the AnKing team) doesn’t have the issue:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.