Images in Image Occlusion can't be edited and new photos uploaded in notes only shows the icon


I have just noticed when trying to edit an image occlusion image that it says the original photo/mask cannot be found and so I’m unable to edit the image occlusion. I was preivously able to do this even when I delete the photos from my desktop after uploading them. Also now when I try to include a lecture snapshot into my “extra” section for reference in a card, all it shows is a photo icon, like it’s copyrighted or something. Have tried putting it in different fields and it shows up when I go to edit the card, just not when i am tested on the card after I reveal the answer. Can you please help? Do i need to update or something?

Thank you!

Update*** it actually doesn’t show the images once I click save after the edit (my photos are still on my desktop too). Just shows little photo icons.

Usually those icons are seen when the files are missing in your folder. Can you check if you have the files on your computer? select “Missed Questions” field, then press ctrl+shit +X to see the actual name files.

If you are using multiple devices, make sure to sync media files as well. There is a checkbox in the general preferences.

Okay. I just checked and the photos i uploaded there are on my desktop still. The image occlusion ones i was trying to edit are no longer on my computer, but in the past I was able to edit them after after they were deleted from my computer so i’m wondering why this is happening now…
I tried the cntrl+shift+X in the missed questions field and nothing happened.

I’m using anki on my computer only.

What do you suggest I do? really don’t want to lose my work or be without the function of adding pictures to my flashcards.


That is not possible. My best guess is that you edited different notes of the same image. When you create occlusions via add-on, each occlusion (i.e. square) is a different note. You are not creating sibling cards on one single note. In that sense, you may have been deleting files on specific notes which you won’t get back.

Thanks. Checked that and still have the issue when i try to put any pictures in

You are able to edit the cards. It’s an option when you open the original image occlusion… You can edit the cards or create new notes/cards

1 Like