Https:// responds with 500 internal server error

I am using Anki 2.1.26 (70784154) on Windows 10 and AnkiDroid 2.11.1 on my Smartphone. I recently changed the note type of about 500 cards on the Windows Desktop Anki. To sync with ankiweb, I had to do a full upload from Anki to ankiweb. Anki told me the difference is to big, it can not be merged. After this I tried to synchronize with AnkiDroid. AnkiDroid can not open the collection any longer. “Check database” does not help.
I also recognized I can not access my decks on any longer. I get a 500 Internal Server Error on the website. Something seems wrong with my decks.
I also tested with Anki on Linux, which I was using sometimes. When synchronize and download from ankiweb, the collection can not be opened on my Linux Anki.
At the moment my decks only work on the Windows Client. What can I do to fix my deck?

Thank you, Martin

I already tried deleting my account on ankiweb, setting up a new one to have a clean start. Than running “check database” on my Windows Anki and syncing afterwards. This didn’t change anything. Trying to access the decks page on ankiweb responds with 500 internal server error. AnkiDroid and Anki on Linux still can not open the collection after syncing.

Please start Anki and execute the following in the debug console:

for d in mw.col.decks.decks.values():
  if "conf" in d:
    dcid = int(d['conf'])
    if dcid == 1:
    conf = mw.col.decks.get_config(dcid)
    if not conf or conf["id"] == 1:
      print("deck was pointing to missing deck options group, fixed")
      d['conf'] = 1

It should tell you it fixed some decks. Then please force a one way sync in the preferences and choose upload, and it should resolve the issue.


Wow, thank you so much! This fixed it. I could sync and all Anki Clients are working.

Thank you, Martin