How to use the next-generation spaced repetition algorithm FSRS on Anki?

I am experiencing a similar issue, but it does not seem to have been solved by the last update.


The reason why the card already has a interval of 1.76 years at the “first” review is that I deleted all review history preceding a certain date by using the debug console.

Intervals before using Reschedule:


Intervals after using Reschedule:


What’s your expected behavior?

I would expect the intervals not to fall from ~ 5 years to 3 days, but rather stay a bit closer to the original interval.

I think the rescheduler is tricked by the reviews I did on 2022-04-17, which were done using a Filtered Deck with “Reschedule cards based on the reviews in this deck” toggled-off. Those reviews all have very short “intervals”, hence the 3 days “Good” interval after the reschedule.

At least that’s what I am guessing by looking at the card info. It seems that all the cards whose intervals drop drastically after the reschedule were last studied in a Filtered Deck with those settings. Also, they were all very mature before I deleted part of the review history.

Here is a sample of a note with 2 cards: Gofile - Free Unlimited File Sharing and Storage
Card 1 was not reviewed in a Filtered Deck with no scheduling; after I run the reschedule it keeps a long interval.
Card 2 was last reviewed in a Filtered Deck with such settings; after I run the reschedule the interval goes down to 3 days.
Both have very long intervals and most of their review history was deleted using the debug console.

Also: if I create a filtered deck containing only those 2 cards, run the rescheduler and then empty it (without studying the cards), I get weird due dates. It already happened to me in the past, but I have not been able to reproduce it consistently.

Before and after:

Thanks for your report. Could you open an issue in the repo of FSRS4Anki Helper?

I will track this bug.


Could you install this patch? Please download it and replace zip with ankiaddon. Then you can install this patch.

Thanks for the patch! The problem regarding the “interval drop” seems to be solved.

However, I still am experiencing the “weird due dates after rescheduling and emptying a filtered deck” issue.

For example, if I create a filtered deck that contains only the cards I included in the sample I sent you, run the rescheduler, then empty the filtered deck without studying the cards, I get the following due dates:

  • Card 1: 1749-08-09 (clearly abnormal)
  • Card 2: 2024-09-09 (looks normal)

It may be worth noting that Card 1 is the one that does not have any “Filtered deck with no rescheduling” reviews in its review history

Could you use Undo rescheduling?


The 2 cards seem not to be affected by “Undo rescheduling”, contrary to at least most of the rest of the collection

They still have the same due dates (1749-08-09 and 2024-09-09)

Due to the update, these cards will not be rescheduled. So I recommend you to fix the abnormal due via set due date.

According to my tests, those cards are still affected by the add-on when rescheduling (just tried again with the same results), but not when undoing the reschedule.

No worries about fixing the cards. I am using a backup copy of my collection.

By the way, I opened a new issue on the repo of FSRS4Anki Helper! As of now it only contains a link to this conversation, let me know if I need to add further details.

I keep getting this error both with the Huggingface link and the Collab.

“not enough values to unpack (expected 4, got 0)”

Is there something I am doing wrong? Also, perhaps you could answer a question for me: Is it necessary to periodically re-run the optimizer to have better settings? Or is using the rescheduling function within the helper sufficient?

1 Like

It is caused by inadequate data.

Is this a recent change? Two months ago I ran the optimizer on this dataset and it worked. This card data has ~50,000 reviews on now ~6,000 mature cards.

Could you share your dataset with me? It will help me debug the optimizer.

Sending via private message

Update: My issue is now resolved with version 3.25.3

hi, did the FSRS handle the “priority” problem that is missing in anki but available in supermemo?

btw, afaik, FSRS only available on desktop. Users mostly also use ankidroid or anki-iOS. Could you point me to some references how to use FSRS both on desktop and ankidroid? or i can simply use together? most people will EDIT the anki on desktop and DO the anki on mobiles i think. thanks

1 Like

AnkiMobile has supported FSRS. AnkiDroid will support it in 2.17.


If you use AnkiDroid, enable the auto-reschedule after sync option in the FSRS helper add-on. This way, when you sync your reviews from AnkiDroid to Desktop, they would be automatically rescheduled according to the FSRS algorithm. For best results, it is recommended to sync the reviews daily. However, it is not very problematic if you sync less frequently.

I applied fsrs add-on to my kanji deck of 3000 cards. About 1030 cards were shown at least once, and without fsrs I have about 50-70 reviews per day.
After rescheduling all cards I got 350 reviews per day. Is such difference an expected behavior? Here is my stats regarding the good/again buttons.