Errors when deleting deck

this error pops up whenever I try to delete a deck

and if I try to rename any deck it says

please help :(( would appreciate any and all guidance

running Anki on mac OS Monterey 12.2.1 (latest) with Anki 2.1.49 (latest)
I have tried to google the error but it only pops up with github links and how to edit code
I tried deleting Anki and redownloading as well which didn’t change anything. I emptied all the empty cards, updated the database, and deleted unused images.

1 Like

The issue is likely an add-on, have you tried disabling them to see if you still encounter this issue?

1 Like

yes i tried disabling all of them and restarting

I can’t seem to reproduce this using a copy of your AnkiWeb collection. Please start Anki while holding down the shift key and confirm you see a popup saying add-ons are disabled, then try again. If you continue to have trouble after that, please try forcing a one way sync in the preferences, and choosing Download.

the shift key solution worked! is there a way to find out which add-on is causing the problem? before, I just went and highlighted all of them and hit the toggle enabled button to disable them.

I think the only option is to disable each add-on individually, restart Anki, test if you can’t reproduce the issue without it, and repeat the process for all add-ons. Post back with the name of the add-on if you find the culprit for the benefit of future users having the same issue.

1 Like

here’s the culprit:

thanks everyone!


A better solution is to disable half of them, check if it is working, then recurse on the right half :stuck_out_tongue:


Did you notice this add-on’s compatibility version?

1 Like

Yeah, binary search :smile: