Error when selecting 'good'

I’m using Anki 2.1.54 on MacOS with a few addons installed. Today I started getting an error when I hit the spacebar to accept a card (as ‘good’). I only get the error every 20 cards or so - not every time. I then have to close and restart Anki to make the error go away until it reappears. The error log is the same each time (copied below). I don’t see a reference to a specific add-on, so I have not yet tried disabling any add-ons. Does anyone have suggestions on what this log is telling me as the root cause of the error?

Edit: I disabled all addons and still get the error after reviewing about ten cards. It’s the same error each time (pasted below).

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 5.14.1 PyQt 5.14.1
Platform: Mac 12.6
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2022-11-11 07:47:57

Caught exception:
Traceback (most recent call last):
File “aqt.webview”, line 568, in handler
File “aqt.reviewer”, line 522, in _onAnswerButton
File “decorator”, line 232, in fun
File “anki.hooks”, line 89, in decorator_wrapper
File “anki.hooks”, line 84, in repl
File “aqt.reviewer”, line 447, in _answerCard
File “aqt.reviewer”, line 454, in _after_answering
File “aqt.reviewer”, line 233, in nextCard
File “aqt.reviewer”, line 340, in _showQuestion
File “”, line 129, in question
File “”, line 145, in render_output
File “anki.template”, line 123, in from_existing_card
File “”, line 156, in note
File “anki.collection”, line 478, in get_note
File “anki.notes”, line 52, in init
File “anki._backend.generated”, line 564, in new_note
File “anki._backend”, line 146, in _run_command

Can you check if you are using time box in anki → preferences → scheduling?

maybe disabling, putting on 0 will help

if the problem is the time box, maybe reinstalling anki will help

I checked and it’s already set to 0. I ran the “check database” and it rebuilt and made a few small changes. Seems to be working better so far, but I’m going to keep testing today.

1 Like

That happens to me occasionally, and “Check Database” fixes it (without any need to restart).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.