Error when adding a new note

I think I’ve figured it out, please let me know if the next beta doesn’t fix it for you.

1 Like

Sweet! I’ve not seen it since upgrading to 2.1.31beta3. Hopefully it’s gone :slight_smile:

Hello, i got this error whenever i tried to add a basic card on Anki.2.1.32 . I initially updated it and got a new add-on (image occlusion enhanced) which initially worked. But on closing and re-opening the app i couldn’t add a basic card. It keeps showing me this error even after i deleted the add-on and checked database. Also my hardware acceleration box is unchecked. I was told to paste the error message on the support site. This is it:

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.32 (dee7d45d) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1
Platform: Windows 10
Flags: frz=True ao=False sv=1
Add-ons, last update check: 2020-08-27 11:39:48

Caught exception:
Traceback (most recent call last):
File “aqt\”, line 493, in handler
File “aqt\”, line 481, in
File “aqt\”, line 190, in _addCards
File “aqt\”, line 593, in saveAddModeVars
File “anki\”, line 87, in save
File “anki\”, line 231, in update
File “anki\”, line 414, in add_or_update_notetype
File “anki\”, line 265, in _run_command
anki.rsbackend.TemplateError: Card template ⁨1⁩ has a problem.

Never mind i have found a solution. After creating basic card, I opened the card and then i figured out the curly brackets weren’t closed. i fixed that and now the basic card adds just fine.