Do not display picture bed pictures without suffixes

v⁨2.1.66,didnt display!
I have tested, v1.4.9+, Qt5 and Qt6 ,all didnt show no suffixes img.

I removed .png from a test file and it worked for me. It may be the mime type it’s being sent as on your machine. @kelciour, do you happen to know if the trick you mentioned on Anki is unable to display any SVG images on my computer - #12 by kelciour also allows changing the mime type for files without any extension?

But that said, you’ll probably find it easier to give the filenames an extension. You can use a bulk renaming program if you have a lot of them.

It doesn’t seem to be possible. I tried jpg, png and webp images with no extension, the Content-Type in the AnkiWebView Inspector will be set to ‘application/octet-stream’ and it appears to be set by the upstream code if the mimetype can’t be guessed from the filename.

But all the images without extension display correctly for me and I can’t seem to reproduce the issue.

1 Like

If adding the extension to the image (that doesn’t display in Anki) didn’t help and Tools > Check Media doesn’t report it as missing or unused, maybe the image (in the folder) contains “%20” somewhere in the filename (or maybe anything with “%”), tried to rename it in the folder and replace “%20” with " ".

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.