Deleting Filtered Deck deleted cards

I regularly make filtered decks to review certain tags, deleting the deck afterwards.

This time I made a filtered deck, synced, then tried to review on a different device. On the other device, despite syncing, the filtered deck did not appear in the deck list. Going back to the original device, opened Anki, the filtered deck now had the “Congratulations! You’ve finished all reviews!” message.

Weird. OK, I thought, I’ll delete that deck and re-generate it.

But when I re-generated the exact same filtered deck, this time it said there were no cards that match that tag.


Opening the browser, all the cards that were in the filtered deck have been deleted – obviously unexpected behavior. (“No cards are deleted when you delete a filtered deck.”)

So, I tried simple Undo, cmd+Z, which undid recreating the filtered deck, but didn’t restore my deleted cards.

Beyond why, how do I retrieve them? My latest backup isn’t recent enough to get them back. (PS - I use zero add-ons, none).

The good news is, I don’t think you’re cards are actually deleted. The browser should only look like that if cards were deleted after it was opened or last refreshed. However, database issues may also manifest like this. This has been improved recently, so you may get more information after installing the latest release.
Deleting the filtered deck could be entirely unrelated and the usual debugging steps may help: When problems occur - Frequently Asked Questions (especially ‘Check Database’).

1 Like

Thanks for the advice.

Some good news, some weirdness.

Check Database restored the “deleted” cards. Wonderful!

I then updated to 2.1.54 Qt6…and the cards were gone again, but this time into a deck called “recovered” (and a huge integer), and all with a due date of 1954-09-05.

Interesting. Now moving them back to the original deck and setting Due Date to today. :thinking:

Sounds like something happened with your database, usually caused by an add-on or some other external tool. If the cards show up properly in the browser now, the issue is probably fixed for good, though.

1 Like