Can't Import Quizlets into Anki

Hello! I keep getting this error message when I try to import quizlets from anki. Will post it below. I’m not sure what I should do. I’ve tried restarting my computer, copying the url from Safari and google chrome, and uninstalling anki and redownloading it and it’s still not working. I can still like use the app just can’t import in anything from quizlet. Any help would be greatly appreciated. Thanks in advanced!

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.66 (70506aeb) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: macOS-13.5.2-x86_64-i386-64bit
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2023-09-29 21:45:24
Add-ons possibly involved: ⁨Quizlet to Anki 21 Importer with audio support⁩

Caught exception:
Traceback (most recent call last):
File “anki.notes”, line 154, in _field_index
KeyError: ‘FrontText’

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “/Users/j*************/Library/Application Support/Anki2/addons21/1362209126/”, line 373, in onCode
File “/Users/j*************/Library/Application Support/Anki2/addons21/1362209126/”, line 420, in createDeck
note[“FrontText”] = item[“term”]
File “anki.notes”, line 162, in setitem
File “anki.notes”, line 156, in _field_index
KeyError: ‘FrontText’

Aside from reporting the issue on GitHub by using the “Contact Author” button at the top of, this reply to one of the recent reviews with a similar error might help to fix it on your own (Tools > Manage Note Types).

KeyError: ‘FrontText’

Hi, 99% percent that you have changed the “Basic Quizlet Extended” note type. You should not do this, this is the “system” note type and the add-on uses it during the import. Try to rename it to something like Basic Quizlet Extended Old and import one more time, the add-on will re-create that note type.

Renamed the note type as suggested and it worked. Thank you!

1 Like

Hi this worked thank you so much!

1 Like