Bug report: 2.1.45

Installation bug on Ubuntu 20.10: After extracting the compressed folder and running ./install.sh, the app installs. Then, when running anki from the terminal, an error message appears:

Python path configuration:
  PYTHONHOME = '/usr/local/share/anki/bin'
  PYTHONPATH = (not set)
  program name = '/usr/local/share/anki/bin/Anki'
  isolated = 0
  environment = 0
  user site = 0
  import site = 0
  sys._base_executable = '/usr/local/share/anki/bin/Anki'
  sys.base_prefix = ''
  sys.base_exec_prefix = ''
  sys.executable = '/usr/local/share/anki/bin/Anki'
  sys.prefix = ''
  sys.exec_prefix = ''
  sys.path = [
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f62aad27740 (most recent call first):
<no Python frame>

I have tried to run QT_DEBUG_PLUGINS=1 anki, but the same error message results.

Does the issue exist with 2.1.44?

No, that version works. Just reinstalled 2.1.44 to check.

Ok, that’s odd - I don’t seem to recall any changes to the packaging recently. Does Alpha 4 work? If not, does alpha 1 work? If so, which alpha did it stop working?

I have not tested the alphas, but the version I tried to install was Beta 1. If nothing in your packaging has changed, it might just be a bug in my setup.