(bug?) CSV Import error bc 'Merge notetype' disabled

Hi there,

I’m trying to import a CSV file but I get this error message:

However, I don’t see any option to enable ‘Merge notetypes’ when importing a CSV file (contrary to when you import an apkg file).

Also, I don’t understand how the notetype can be changed with a CSV import. I’ve analysed the particular notes that weren’t imported, and it appears to be notes with only one field filled. Notes with more than one field are imported just fine.

Any thoughts?

•I’m using Anki ⁨23.12.1 (1a1d4d54)⁩ on MacOS Sonoma 14.1.2 (23B92)
•I’ve disabled all add-ons and restarted Anki.
•Here are my available import options:

•Here’s a screenshot of the same error message when trying to import a different CSV file (this time, even rows that contain content for several fields aren’t imported)

I assume your CSV files have GUID columns?
It looks like in that case, only notes with the selected notetype can be updated. We should be able to remove that restriction and improve the message.

Thanks for your reply, Rumo.

That’s the weird thing: all of the rows in my CSV file are supposed to become the same notetype (though the notetype is not specified in the CSV file), and I get the same issue when I import the CSV file into a different profile with an empty collection (where I only imported 1 note as apkg to import the notetype with it).

My CSV files do not have GUID columns. I’ll try with a GUID column and report back (although that means I’ll lose all the edits I’ve been making to the CSV).

Oh, now I see. Seems like the summary is always showing the same message about notetype conflicts when a note could not be imported, no matter the reason.
You can see the actual reason in the Details table by hovering the Status column. In your case, it might be that the first note field is empty.

2 Likes

Ohhh that’s right! Thank you. I never understood the point of skipping notes which first field is empty even if the next fields are filled. I guess this is why including the GUI solves the issue.

1 Like

The first field is required, among other things, because it is used to find duplicates.
If there is a GUID, Anki can use this instead, making those imports a bit special.

1 Like

I’ve checked everything and now it works. Thank you so much Rumo!

If anyone else has a similar issue, here’s what fixed it (Rumo’s idea): Anki won’t import content whose first column/field is empty, so it helps to include the GUID. To do that, check “Include unique identifier” in the Export dialog window: