Browser appearence

Dear Anki-Gurus,
I’ve recently updated to:
Version ⁨2.1.46 (94913ec2)⁩
Python 3.8.6 Qt 5.14.2 PyQt 5.14.2

Its brilliant. Except the Browser line spacing is too large. I often review my cards in browser mode and like the compact view of earlier versions.
i see there is an options for “browser appearance”.
Does anyone know the commands I’d insert into this (currently blank) box to reduce line space?

Many many thanks,

If I recall correctly, Anki does not expose a way to change the line height, though you can adjust the font size. Maybe there’s an add-on that lets you customize it further?

1 Like

Many thanks, I’ll keep eyes peeled for Add-ons.

You can use Browser Resizer for that.


I have a similar question but not referring to the height of the lines in the browser itself but in the editor space below. Also in any edit window or add-note window the line height is much bigger than before. This may look nice if the contents of a field are only 2 or 3 lines but for extensive content it is very annoying. Is there any way to customize it?

Browser Resizer can do that as well.

1 Like

I have tried it. I downgraded and tried it in Anki 2.1.44 and it works nicely there, thanks, but it doesn’t work in 2.1.47. Is there going to be an update?

Works fine for me on 2.1.47.

1 Like

I tried disabling other Add-ons one by one, then in frustration I disabled every add-on except this one and it still doesn’t work in 2.1.47 Any ideas?

Maybe you’re not using the most recent version of the add-on?

Just deleted it and reinstalled it. Still doesn’t work.
Sorry to bother you with this. Are you a developer? Or should I post a new thread for this?

I’ve contributed a lot of the new browser code and wrote the update for Browser Resizer. It’s working fine for me and I’m pretty certain that’s the version available on Ankiweb right now. (Can’t check before Sunday though.)

It’s generally advisable to open a new topic, but I’m not sure there’s much more that could be done in this particular case.

Are you sure you’ve configured the add-on correctly?

1 Like

I tried configuring the add-on in both 2.1.44 and 2.1.47. In 2.1.44 I can change the editor font-size but of course the editor shrink doesn’t do anything because it is already shrunk. In 2.1.47 also I can change the editor font-size, so that says the add-on is installed correctly, but the editor-shrink does nothing. Large fonts still have a proportionately large space between lines. Again tried it with all other add-ons disabled. Considering the possibility that either the large size of my collection or some card in my collection might be causing the problem I moved my Profile folder out of the Anki folder and started Anki with a clean new profile, added a couple of basic cards, and still the same situation: can change font size but no shrinking.
As an aside, just my personal preference but I think the window close button on the configuration window should be equivalent to the OK button, not the Cancel button.

Does that mean other parts of the add-on do work for you? That’s kind of vital to know.

I don’t understand what you mean by that, but if you think you’ve found a bug in Browser Resizer (or a regression to a previous version) you should report it using one of the contact options on the add-on page.

1 Like

Sorry for the late response. In 2.1.44 the add-on works well. It can change (override) the font-size of the fields in the editor as well as change the spacing of the cards in the browser list. But the editor line height is not affected at all by the “editor_shrink”. That is no problem there since the default editor line height in 2.1.44 is normally small. My desire is that 2.1.47 not have the extra line height in the editor. The “editor_shrink” set to either true or false changes nothing that I have noticed. I presumed “true” was supposed to change the editor line height back to the former 2.1.44 line height.

I just checked again. Even in 2.1.45 the font size in the editor can be changed but the spacing in the browser list cannot. Same in 2.1.47. That is with all other add-ons disabled. Okay, I will do as you suggest and report it on the add-on page. Thank you and sorry to have bothered you.