Blank Card Browser


In the Android app, when I click on “Card Browser”, I don’t see the cards. It’s blank with only “Question” ans “Answer”. Has anyone experienced this? What is the solution?

I don’t know if anyone has had this problem, I tried searching the forum but as I don’t speak English very well, I couldn’t find anything.

Thank you !

Is it possible the fields here don’t contain anything?

There’s data. I’ve just done some tests. Packages with text display well and packages with images display in white. But it worked before. And it works on my computer.

  1. Is this happening for all decks/cards – or just certain ones?
  2. When you choose other things from the column dropdowns (besides Question and Réponse) do you see anything show up then?
  3. What is on these cards – text, images, etc.? Can you post a screenshot of what you see when you open one of these to edit the note – and of what the card preview looks like?
1 Like

If I understand correctly how this works, then “Question” is the first field on the front of the template, and “Answer” is the first field on the back of your template. Accordingly, we need to see the note types and how you fill in the note fields.

1 Like

I was wrong, not the first field in the template is used, but all the fields in the order in which they are in the template.

Open this fullscreen for a tutorial on changing what Question/Answer is:

  1. It’s only for the cards who have images
  2. Yes, I see informations. I put you an attachment: when I choose “sort” and when I click on a sorted card
  3. there are images on the cards. I’ve included the attachments when I edit a note and when I modify it.

When I sort a note:

When I click on a sorted card:

When I edit a note:

When I modify a note;

Excuse me, Keks, I’m not sure I understand very well. Is it all right if I show you these screenshots?

I’m not sure how to do that, since these are images. I don’t think there’s any notion of language?

On the other hand, you made me think of something. When I click on “preview”, I can see the cards. I don’t know if this is a lead?


You have two fields in your cards both of which have images in <img> tags. What David showed you will not help. The card browser would not display them. I saw how the card browser behaves in my case (latest alpha).

I’m not sure if this is a regression but this does make sense to me. It doesn’t help most people to see the filenames in card browser. Better be blank.

1 Like

Here’s what Keks meant: Question in AnkiDroid shows you the fields in the front. Answer in AnkiDroid shows you the fields on the back of your card.

In your case both of them are Images which AnkiDroid isn’t displaying. From what I see AnkiDroid doesn’t display HTML tags in Browser. In fact it doesn’t show anything that might come in between < >. @David is there a way to make them show up in browser?

1 Like

Anki desktop
Field=<img src="123.jpg">
Field=<img src="123.jpg">

I think we should consider this an ankidroid bug.

Yes I agree. Also anything in between <> not getting displayed certainly is unhelpful. People use these symbols in Math and Science not just in HTML tags.

To display filenames in the list, you may want to check if the following setting has been enabled:
‘Settings’ > ‘Appearance’ > ‘Display filenames in card browser’

If the option has been disabled, the non-display of filenames in the card browser is an expected behavior of the app.


Yes that solved the problem.

1 Like

Yes, the option was disabled!
Now I see the filenames in the card browse.
I understand why it was white.

Why when it’s a text, the text is displayed and when it’s images, the name is displayed and not the image itself?

Is this normal application behavior?
(I think it’s the same question as Keks)

Filenames of the card displayed when it’s an image;

Text displayed when it’s a text:

Yes. It is. There are other instances of similar behaviour, underlining, bold, italics and other formatting not appearing. Anything in HTML won’t appear in Browser.

Displaying images might be a good idea though. Making it optional in settings too. Plus being able to play the sound files from the browser. Saves the extra three-four clicks in trying to play it in preview.

(also, why literally everyone seems to be learning japanese? it’s too popular atm. japanese beginners/intermediates everywhere)

1 Like

Thank you for all these details, it’s very interesting.
In any case, it’s a wonderful tool for learning and revising languages.

(Yes, Japanese and Japan are very popular. I think there’s a whole range of reasons for this, including the influence of pop-culture (anime, manga and video games), technology and innovation, traditions and culture (tea ceremony, calligraphy…), history (samurai…), cuisine, tourism (historical heritage, dynamic cities and picturesque territories …).

1 Like