Bad behavior when Anki displaying the answer

Hello. I am using Anki 2.1.42 in Debian Testing. When I review a card (with any of Again, Hard, Good, Easy), the answer is displayed. The expected behaviour is that the answer section (below the <hr id = answer> in the Back Template) would be displayed, but the whole card is shown instead. In this gif you can see what I am talking about.

  1. I answer the card and the whole card is shown
  2. I undo the review
  3. I answer the same card and the answer section (below <hr id = answer>) is shown (expected behaviour).

What’s wrong with this?

I presume you mean that it’s not scrolling down to the answer. It does for me - have you ruled out add-ons as the cause?

I presume you mean that it’s not scrolling down to the answer.

Yes that’s what I mean. I tried with all the addons disabled and creating another profile and the behaviour is the same.

I found in the changelog that version 2.1.37:

  • Fixed review screen not automatically scrolling to answer (thanks to Henrik).

Maybe it is related?

My guess is that it is scrolling to the answer area, but the image is taking a while to load, and is loading after that. Is your video driver set to software in the preferences?

On my pc I don’t see lag, maybe it’s the screencast program. The video driver set in preferences is “software”, but I also tried with OpenGL (+restart) and I didn’t notice any changes. Here there are 2 videos showing the behaviour (the first one is like the gif posted above).

I noticed that the card is automatically scrolling to answer in 2 situations:

  1. Answer the card, pass to the next card and go back to the previous one with UNDO (CTRL+Z) (See video 1)
  2. Edit a card, select the Back Template, select either Front Template or Styling, go back to Back Template. (See video 2).

Did you try without the Javascript?

1 Like

Yes, I tried deleting the js script from the cards.
Here is my last card template that I have tried:


.card {
    font-family: roboto,sans-serif; /* FONT FAMILY */
    font-size: 20px; /* FONT SIZE */
    text-align: center; /* ALIGN TEXT */
	line-height: 1.2; /* DISTANCE BTWN LINES */
    color: #657b83; /* FONT COLOR */
    background-color: #fdf6e3; /* BACKGROUND COLOR */
.card.nightMode {
    color: #839496; /* FONT COLOR */
    background-color: #002b36; /* BACKGROUND COLOR */




<hr id="answer">

When returning to the preferences, it’s showing OpenGL? If so, you could try the following in your card template:

<script>aFade=500; if (typeof anki !== 'undefined') anki.aFade=aFade;</script>

You should see the question fade out and answer fade in. Does it make a difference to the scrolling?

I have set Video Driver OpenGL (+restart Anki) and put the script in my Front Template. The result was the same, here a video.

Hmm, that link doesn’t seem to be working for me at the moment. In any case, could I trouble you to move two problem cards to a separate deck, export it, and share it somewhere?

Of course! Here is a sample deck with a few notes Default.apkg - Google Drive

Thanks, I was able to reproduce the issue with that deck. It is caused by the images loading, and a fix will be in the next update.