Audio is broken

Yeah something is definitely wrong. It seems as if mpv doesn’t work. This causes audio to never play. The solution told to me when searching isn’t going to work because I already had the version of mpv from the extra repo installed.
I tried disabling Qt compatibility and using AUR anki. I’ve checked the database and media already, and it still didn’t work.
Debug info:

Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: Linux-6.8.7-zen1-1-zen-x86_64-with-glibc2.39
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2024-04-23 16:24:25

Caught exception:
Traceback (most recent call last):
  File "aqt.mpv", line 373, in _send_request
  File "aqt.mpv", line 354, in _get_response
aqt.mpv.MPVCommandError: invalid parameter

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "aqt.webview", line 604, in handler
  File "aqt.reviewer", line 659, in _onTypedAnswer
  File "aqt.reviewer", line 422, in _showAnswer
  File "aqt.sound", line 150, in play_tags
  File "aqt.sound", line 209, in _play_next_if_idle
  File "aqt.sound", line 216, in _play
  File "aqt.sound", line 429, in play
  File "aqt.mpv", line 595, in command
  File "aqt.mpv", line 375, in _send_request
aqt.mpv.MPVCommandError: ['loadfile', '/home/kxeo/.local/share/Anki2/User 1/collection.media/0593.mp3', 'replace', 'pause=no']: invalid parameter

The issue isn’t isolated to anki, multiple other things that use loadfile are broken after the update. The solution that worked for me was downgrading mpv to 0.37.0-3 for now, you can check the arch wiki on downgrades if you need help.

2 Likes

Bump, @nanasi solution is exactly what you need. Mpv 0.38 seems to break anki for now. Recommend you not only downgrade, but also set pacman to ignore the mpv package from upgrading

I went with upgrading to 0.38 and putting the MPV 0.37 binary only on Anki’s PATH.

That way I get to use the latest version, and when 0.37 inevitably breaks due to dependencies, the issue will be limited to Anki.

I am also on Linux (Siduxion). I have just installed mplayer instead of mpv and now sound in anki is fine.