Arch Linux - Sound doesn't work on 23.12.1 with mpv

This has worked before with my decks and now suddenly it shows that Anki has encountered an error that is caused probably from the decks. However, I disabled all of them and still has no sound.

I’ve tried everything from pacman -Syu, (luckily) reinstalling the system with Arch, but no chance. Since I am using a very old machine, it isn’t possible to run the latest Anki, despite having a AMD64 architecture (sadly).

Here is the copy of the debug in Anki:

Anki 23.12.1 (1a1d4d54)  (ao)
Python 3.9.15 Qt 6.6.1 PyQt 6.6.1
Platform: Linux-6.8.7-arch1-1-x86_64-with-glibc2.39

Traceback (most recent call last):
  File "aqt.mpv", line 371, in _send_request
  File "aqt.mpv", line 352, in _get_response
aqt.mpv.MPVCommandError: invalid parameter

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "aqt.webview", line 50, in cmd
  File "aqt.webview", line 157, in _onCmd
  File "aqt.webview", line 686, in _onBridgeCmd
  File "aqt.overview", line 97, in _linkHandler
  File "aqt.main", line 740, in moveToState
  File "aqt.main", line 761, in _reviewState
  File "aqt.reviewer", line 174, in show
  File "aqt.reviewer", line 194, in refresh_if_needed
  File "aqt.reviewer", line 252, in nextCard
  File "aqt.reviewer", line 378, in _showQuestion
  File "aqt.sound", line 150, in play_tags
  File "aqt.sound", line 209, in _play_next_if_idle
  File "aqt.sound", line 216, in _play
  File "aqt.sound", line 431, in play
  File "aqt.mpv", line 593, in command
  File "aqt.mpv", line 373, in _send_request
aqt.mpv.MPVCommandError: ['loadfile', '/home/arch/.local/share/Anki2/User 1/collection.media/tosend.mp3', 'replace', 'pause=no']: invalid parameter

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
FSRS4Anki Helper ['759844606', 2024-04-24T19:42, 'None', '']
Image Occlusion Enhanced ['1374772155', 2022-04-09T01:15, 'None', '']
Leech Toolkit ['368380974', 2024-04-01T12:02, 'None', '']
Review Heatmap ['1771074083', 2022-06-29T19:43, 'None', '']
The KING of Button Add-ons ['374005964', 2024-01-27T03:19, 'None', '']
Zoom 23 - Keep zoom level after reboot Fixed for Anki 23 by Shige ['1923741581', 2024-04-22T19:47, 'None', '']
extended editor for field for tables searchreplace ['805891399', 2023-07-31T08:12, 'None', mod]

===IDs of active AnkiWeb add-ons===
1374772155 1771074083 1923741581 368380974 374005964 759844606 805891399

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])


2 Likes

Definitely something with mpv, as I didn’t notice that they updated. Downgraded to 0.37.1. More info here - Arch Linux Archive - ArchWiki, or pacman -U https://archive.archlinux.org/packages/m/mpv/mpv-1%3A0.37.0-3-x86_64.pkg.tar.zst

2 Likes

This bug was fixed in Anki Version ⁨24.04.1. Reference Fix mpv loadfile syntax change (#3105).