Anki not working after installing a new monitor and graphics card update

Hi, I’m not very technically inclined, but I’ve been using Anki without issue for years until yesterday.

I installed a new monitor on my computer yesterday. I have a 3-monitor setup and an NVIDIA GeForce 1060 graphics card. My two other monitors are connected to my computer on a DP port, this new one is using and HDMI port. When I installed it, a new display adapter showed up which seems to be associated with the new monitor. I also updated the driver for the NVIDIA card.

After that, I tried to run Anki and got this error message:

"Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QflagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stecilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile).
This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL2.0 or higher, or if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLEv2.dll and d3dcompiler_*.dll) are available in the application executable’s directory or in a location listed in PATH."

But then it also suggested I close Anki and restart to use a different driver. I did this and it opened, but when I tried to study a deck, Anki froze and stopped responding.

So then I downloaded and tried to install the latest version 2.1.30-windows. But when trying to install, the installation failed with the error: “Error opening file for writing: C:\Program Files\Anki\mvp.exe Click retry or try again or Cancel to stop the installation.” Retrying wouldn’t work.

So then I downloaded the last stable 2.1.26. I was able to install it, but when I tried to run Anki, it asked if I had forgotten to downgrade my profile because the current one needed a newer version. It opened a window where downgrade and quit was an option, but when I tried that, it said my profile couldn’t be downgraded.

Then Windows prompted me to restart to update, I did that and was able in install the newest version, but now when I try to run Anki, the same profile window comes up and a prompt to download the latest version of Anki (which, I now have installed), and clicking on “Open” just causes Anki to flash and then not do anything.

Any help would be appreciated :slight_smile: :slightly_smiling_face:

  • Try to start Anki and hold down the shift key to turn off the add-ons.

    image

  • If it doesn’t help, use Start>Run or press Win+R, type cmd.exe, copy-paste cd \program files\anki & anki-console and press Enter.

    Presumably Anki will fail to open like before. But it should give you some lines of debugging info; please copy&paste or screenshot the text and attach it to your support ticket.

    https://anki.tenderapp.com/kb/problems/when-anki-doesnt-start-on-windows-debugging-steps

1 Like

I have a question irrelevant to the topic.

How can I get a prompt message about availability of a new version of Anki? I am asking about @janiecek777 screenshot in the first post. I have never got such message.

For me it appears if I open Anki 2.1.15.

The lack of a “downgrade and quit” button in the bottom right of the profiles screen indicates you’ve accidentally opened an older version - if you did install 2.1.30, perhaps you installed it in a different location, or the older version was installed elsewhere?

Thank you very much for your suggestions. I tried opening Anki from the console with the command you gave and it seems to have worked – it opened. After that first time I was able to open it again from my pinned Anki icon. I think I’m back to running 2.1.29, but I’m afraid to mess with it anymore.

One thing that continues to happen is that if I attempt to use my hotkey language input shortcuts to change languages (I’m using Anki for foreign language study), then Anki freezes and becomes unresponsive. Actually, then everything on my computer becomes unresponsive and I am compelled to end Anki through the Task Manager. If anyone knows of a fix for this, please let me know!

Thank you again for your help!

Thank you, yes, at this time I purposefully installed an older version to see if that would fix my problem, but when prompted to downgrade, clicking that downgrade button just gave me an error message that it couldn’t be downgraded. I’m not sure why. But now one of the newer versions seems to be working. :slight_smile:

Since you’re on Anki 2.1.29, I think, it’d be better to download and install the latest Anki 2.1.31 beta version - Anki 2.1.31 Beta

About the window freezing while using keyboard shortcuts to change input language, I’m not sure about it and it might not help, but maybe try to enable hardware acceleration in Anki.

1 Like

What hotkey are you using? I seem to recall some users having trouble with a particular shortcut, but it worked correctly when they used a different hotkey.

Thank you again! I have updated my graphics card driver again, in the interim. My more-tech-savvy brother assisted in that. And per your suggestion, I have downloaded and installed Anki 2.1.31. When I went to the tool options hardware acceleration was already enabled. Unfortunately, the program is still freezing when I attempt to use my hotkeys to change the language. This problem doesn’t seem to happen if I change languages from the language area near the system tray (if I’m using understandable terminology) or if I use the default Windows Key + Space to toggle between languages.

I really appreciate your suggestions again! Maybe it is something weird with Windows itself, I’m not sure. Even before this problem my hotkeys get unassigned if I ever restart my computer too.

Hi! The hotkeys I use are ctrl + 7, 8 , or 9 usually. I think I have tried all of these sequences and they all cause the same issue.

image

Unfortunately this is an issue with the toolkit Anki is built on, so I’m afraid the only suggestion I have for now is to use the Windows key + space for now. :frowning: