Anki not starting on Linux ("Error loading '⁨software' graphics driver.")

Same problem as here, but I’ll provide a bit more information:

I’m on Ubuntu 18.04 and suddenly ran into this issue with my 2.1.x version of Anki. Tried switching to 2.1.38 but the problem persists.

When I run ./Anki I get “Error loading ‘⁨auto⁩’ graphics driver. Please start Anki again to try next driver.”

Running
$ QT_DEBUG_PLUGINS=1 ./Anki
I get the following output:
https://pastebin.com/raw/aKu8HjrV

Also tried putting ‘auto’ / ‘software’ into ~/.local/share/Anki2/gldriver. But this had no effect.

What does the following report?

~/anki-2.1.38-linux$ ldd bin/PyQt5/Qt/plugins/xcbglintegrations/libqxcb-glx-integration.so

and what about the other file in that folder?

this probably won’t help anyone, but here’s what I did:

  • didn’t try if the problem still exists
  • ran ldd on libqxcb-glx-integration.so (output)
  • ran an apt grade (list of packages upgraded) and restarted system
  • ran ldd on libqxcb-glx-integration.so again (output)
  • tried to start Anki, worked

So, no clue what the problem was. No clue whether or not some package upgrade did something. But it works now.

I also just had a fun time running down that error. Remember to reboot after kernel or graphics driver updates :wink:

1 Like