Anki not starting in Windows 11


This is really odd because my Anki was working just a few days ago…but now when I double click on the app on my Lenovo, it won’t even open. I’m not met with any pop-up errors either. I’ve tried restarting my computer, uninstalling (plus deleting Anki folder), reinstalling multiple versions (qt5, 2.1.60, 2.1.35-alternate), changing the decimal indicator in the control panel. None of these options have worked. Would anyone be able to assist? Thank you!

See Startup Issues - Anki Manual

Yes I’ve tried all the options in the manual.

Could you see if this issue is the same as yours? Anki 2.1.61 Qt6 appears in the Taskmanager but does not launch

It is not. When I click on the app, it appears in Task Manager for a few seconds and then disappears.

Could you temporarily remove the add-ons in addons21 folder (not sure if this is the path to find on Windows %APPDATA%\Anki2)

Just tried that. Moved it to a different folder and then deleted them all together. Restarted computer and still doesn’t run

Could you paste the logs you see in debugging in preformatted text (crtl + E)

Yes it’s pasted below. I’m currently running 2.1.41

[9240] PyInstaller Bootloader 3.x
[9240] LOADER: executable is C:\Program Files\Anki\anki-console.exe
[9240] LOADER: homepath is C:\Program Files\Anki
[9240] LOADER: archivename is C:\Program Files\Anki\anki-console.exe
[9240] LOADER: C:\Program Files\Anki\anki-console.exe contains a digital signature
[9240] LOADER: No need to extract files to run; setting extractionpath to homepath
[9240] LOADER: SetDllDirectory(C:\Program Files\Anki)
[9240] LOADER: Already in the child - running user’s code.
[9240] LOADER: Python library: C:\Program Files\Anki\python38.dll
[9240] LOADER: Loaded functions from Python library.
[9240] LOADER: Manipulating environment (sys.path, sys.prefix)
[9240] LOADER: sys.prefix is C:\Program Files\Anki
[9240] LOADER: Pre-init sys.path is C:\Program Files\Anki\;C:\Program Files\Anki
[9240] LOADER: Setting runtime options
[9240] LOADER: Initializing python
[9240] LOADER: Overriding Python’s sys.path
[9240] LOADER: Post-init sys.path is C:\Program Files\Anki\;C:\Program Files\Anki
[9240] LOADER: Setting sys.argv
[9240] LOADER: setting sys._MEIPASS
[9240] LOADER: importing modules from CArchive
[9240] LOADER: extracted struct
[9240] LOADER: callfunction returned…
[9240] LOADER: extracted pyimod01_os_path
[9240] LOADER: callfunction returned…
[9240] LOADER: extracted pyimod02_archive
[9240] LOADER: callfunction returned…
[9240] LOADER: extracted pyimod03_importers
[9240] LOADER: callfunction returned…
[9240] LOADER: Installing PYZ archive with Python modules.
[9240] LOADER: PYZ archive: PYZ-00.pyz
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running
[9240] LOADER: Running

Could you try on 2.1.61 qt6 and qt5 with preformatted text (Crlt + E)

Sadly this goes beyond of what i know, found this thread in case if the problem is about MEIPASS2 IS NULL (problem with python38.dll which don’t seem your case)

please wait for another dev/user to respond

Appreciate the help! I’ll try it out in a few hours when I get back to a computer. For what it’s worth, I tried it in Windows Safe Mode and Anki managed to open up. I’m just not sure what background processes to pause if that seems to be the case.


Wondering if anyone is still able to help? I’ve got it to work a few times by removing the add-ons. But every time I shut off the computer for the day and get back on to start Anki, it won’t start. I’ve now tried removing the add-ons and that isn’t working. It only starts in Safe Mode. I’ve tried uninstalling and downloading the 2.1.35 version and it’s still not opening.

I got the same problem. I use 2 pc monitors via an ICY BOX. In this configuration anki does not start. if I connect only one monitor directly to the PC, anki starts without problems.

So odd. This was the issue for me too. Disconnected from my double monitors and it started working again. Thank you!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.