Anki hangs immediately when you do Ctrl+Shift+<number> on a newly rebooted computer (with weird workaround)

Version ⁨2.1.65 (latest)⁩
Python 3.9.15 Qt 6.4.3 PyQt 6.4.0
Windows 11 = latest (22621.2134, but also happened with the previous month’s version)

Reboot computer before doing this. Launch Anki. Press Ctrl+Shift+7, or any other number. Anki hangs (see details below). Terminate Anki.

Now press Windows+L to lock the screen. Then immediately unlock the screen (in my setup this requires re-entering a passphrase or PIN). Launch Anki again. Now Ctrl+Shift+7 doesn’t hang anymore.

Anki almost immediately goes into “Not Responding” mode, with busy-mode circular cursor, text grayed out, and the X “close-window” user interface element in the top-right corner turning red.

Clicking on the X to close the Anki window causes the “anki.exe is not responding” standard operating system popup to appear. The options are:
→ Close the program
→ Wait for the program to respond

Clicking the “Close” option generates “Hang on while Windows reports the problem to Microsoft…”, and then the program is terminated.

It doesn’t matter if the window is the Decks screen or the Browse screen or whatever.

Actual Anki keyboard shortcuts like Ctrl+Shift+i for “Import” or Ctrl+Shift+n for “Manage Note Types” work fine.

By the way, Ctrl+Shift+number can be used in Settings, in the “Input language hot keys” dialog box in Time & Language > Typing > Advanced keyboard settings. But “not responding” happens regardless of whether the number used corresponds to a defined hot-key combination or a non-existent one.

I don’t know if this affected previous Anki versions because I didn’t try to define or use the “Input language hot keys” feature of Windows earlier.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.