Anki Forums

Anki fails to launch after new update

I use a Manjaro (KDE) system:

CPU: Dual Core Intel Core i5-6200U (-MT MCP-) speed/min/max: 500/400/2800 MHz
Kernel: 5.4.97-1-MANJARO x86_64 Up: 16m Mem: 3074.6/7855.0 MiB (39.1%)
Storage: 931.51 GiB (93.6% used) Procs: 219 Shell: Bash inxi: 3.3.01

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

After a recent update, my Anki Desktop application fails to launch with the following message:

Traceback (most recent call last):
  File "/usr/bin/anki", line 3, in <module>
    import aqt
  File "/usr/lib/python3.9/site-packages/aqt/__init__.py", line 22, in <module>
    from aqt.qt import *
  File "/usr/lib/python3.9/site-packages/aqt/qt.py", line 13, in <module>
    from PyQt5.QtCore import *
ModuleNotFoundError: No module named 'PyQt5.sip'

I tried reinstalling Anki and also tried uninstalling and reinstalling the PyQt5 packages. Please let me know what can I do to resolve it. Thanks in advance. :slightly_smiling_face:

Please see When problems occur - Frequently Asked Questions