Anki crashing after opening stats window - Exception code: 0xc0000005

i tried to do some midnight cards. when i closed the card editor, anki crashed just as before.

event log

Faulting application name: anki.exe, version: 0.0.0.0, time stamp: 0x6279dde1
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000002607dbe7c20
Faulting process ID: 0x36e8
Faulting application start time: 0x01d866ece24b10ff
Faulting application path: C:\Program Files\Anki\anki.exe
Faulting module path: unknown

note that the Faulting module path is now labelled as “unknown”

i will test it some more tomorrow (aka today) morning

I am not able to reproduce this. I suspect it’s a video driver issue, and you may be able to work around it by choosing software mode: Display Issues - Anki Manual

1 Like

ah!
putting it on auto fixed the problem. genius! (it was on OpenGL)

the problem returned again!

oh wait never mind. i spoke too soon!

my friend at the library had the same issue. we tried the solution you gave in the manual, and the issue persists.

fails with software and with auto

it also fails with OpenGL

but strangely enough, setting it to auto fixed this problem here: Error when deleting a card from browser

similar issue Mac app crashes everytime when I close a window. this happened to me when I closed the export from browser dialog box

try these steps maybe (skip the step where you review 1 card)

  1. open Anki
  2. click on a deck to study
  3. click on Study Now
  4. open the Stats window (which shows your profile statistics)
  5. close the Stats window
  6. Anki crashes!

here is the cmd startup

Anki starting...
Initial setup...
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run...
Qt info:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:
  *  application-name Anki
  *  browser-subprocess-path C:\Program Files\Anki\lib\PyQt6\Qt6\bin\QtWebEngineProcess.exe
  *  create-default-gl-context
  *  disable-es3-gl-context
  *  disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  *  disable-speech-api
  *  enable-features NetworkServiceInProcess,TracingServiceInProcess
  *  enable-threaded-compositing
  *  in-process-gpu
  *  use-gl desktop

Starting main loop...

used Qt5, and the issue cannot be reproduced there…

Qt6 installation:

  1. immediately after installation, the issue cannot be reproduced
  2. however, when i closed down anki, and launched it again, the issue returned. extremely odd

this is unfortunate, because my pc is quite a high end one, and I thought it would be able to handle an SRS app :smile::/.

given that the issue continues to occur regardless of the fact gldriver6 is set to auto or software, and given that the issue does not occur in Qt5: Could it be Qt6 that is the issue? because i simply cant see why my pc wont handle anki when it has handled software and games that are way heavier and more demanding

also, if you follow the following steps, anki will not crash:

  1. open Anki
  2. click on a deck to study
  3. click on Study Now
  4. open the Stats window (which shows your profile statistics)
  5. scroll down to the bottom of the screen
  6. click on one of the Added graph bars
  7. browser will open
  8. close the stats window
  9. close the browser
  10. Anki is doing fine!

Now, if you repeat the steps i initially posted, anki will crash again!

is there a debug mode to capture what is going on?

updated steps!

you don't need to go into study mode. here are the new steps:
  1. open anki
  2. press T (to get Stats)
  3. press Esc (to close Stats)
  4. anki crashes

Those steps do not trigger the issue for me. It is quite possibly a bug in Qt that is timing-dependent, and your computer may just fast or slow enough to trigger it.

Do you get the same crashes with 2.1.51-qt6?

Morning,

Ahhhh! of course! i completely forgot to test on the previous release. my apologies dae!

i have just tried it on 2.1.51-qt6

i got these two errors when I first launched anki. i closed it, and opened it again.

it worked fine. i tried the steps i outlined above, and no crash!

i turned off anki again, and opened it a 2nd time. no crash!

i turned off anki again, and opened it a 3rd, 4th, 5th, and a 6th time. no crash (at all)!

I tested with gldriver content auto and software. No crash in either of them.

image

image

here is a summary of what happened so far (since starting this post):

  • 2.1.52-qt6: CRASH
  • 2.1.52-qt5: ok
  • 2.1.51-qt6: ok

I’ve added this to the issue tracker: closing webview windows causes crashes on some machines · Issue #1879 · ankitects/anki · GitHub

Thank you dae! if there is anything else i can do to help resolve this issue, let me know!

i dont really use python, but if you would like me to do some live debugging and testing with the assistance of a developer, then i am happy to do that

A new issue development

so i created a new profile in anki 2.1.52-qt6, and i have tried the steps i outlined above. there was no crash!

the crash was only occuring with my OLD profile (i.e. the profile which i had since the beginning).

however, when i exported the content (i used both types of export) from my OLD profile to my NEW profile, the crash started to occur again.

in summary, the crash does not occur on an empty/small profile. CORRECTION: the crash does not occur on profiles that have small/no repetition data (I have import a deck with 13k cards and no rep history. the crash did NOT occur)

i can now confirm that the crash does not occur (kind of) if you have a small/no repetition history.

steps i have taken (no crash steps):

  1. delete history from the database
  2. open the profile which had the crashes
  3. do the crash-inducing steps i have outlined above
  4. no crash!

However, if you do the following, you will get a crash (CRASH steps):

  1. delete history from the database
  2. open the profile which had the crashes
  3. Check database and wait for it to finish
  4. quickly press T to get Stats
  5. close Stats (Esc)
  6. crashed!

I don’t know whether you used empty profiles or not, but perhaps, what you can do in order to reproduce the issue is (unless you have already done that):

  1. download a relatively large deck (say 13k cards. you can use Brosencephalon.com — Brosencephalon Flashcard Decks & Collections)
  2. reschedule all of the cards (using shift+ctrl+d from the browser)
  3. close anki and delete all of the database rep history of that profile
  4. open anki and choose the profile you have just cleaned
  5. Check database and wait for it to finish
  6. after that’s done, quick press T to get Stats
  7. close Stats (Esc)
  8. you should expect a crash. if not, then repeat steps 4-8 again (after restarting anki)

sorry post is slightly incoherent. let me know if anything is unclear

I have experimented with different collection/history sizes and even tried adjusting the code to alter the timing, but still have not been able to trigger the crash on machines here.

Let’s continue this on Crashes with 2.1.52 / 2.1.53rc