Anki Forums

"Anki could not create its data folder" on Mac Big Sur 11.3.1

I recently upgraded my Intel Mac to Big Sur and couldn’t launch Anki (2.1.40), the error message being “Anki could not create its data folder. Please see the File Locations section of the manual, and ensure that location is not read-only.” Then I followed directions from other threads, but none worked even with the following:

  • Anki does have full disk access on my system

  • I have read and write access to both ~/Library/Application Support and the Anki2 folder, so I don’t think this is a read-only issue

  • renaming Anki2 doesn’t help

  • I’ve tried the solution from Anki could not create its data folder (Mac Big Sur) (deleting the Anki2 folder, uninstalling and then reinstalling), but the same issue keeps coming up

  • installing a different version of Anki (2.1.43) doesn’t work either

Am I missing something?

That’s strange. Do you use any third-party antivirus/firewall/etc software on the machine?

If you run Anki from a terminal, you could try providing it with a custom data folder location:
https://docs.ankiweb.net/files.html#startup-options

Strange indeed. I tried with my antivirus software off and had the same issue, so I don’t think it has to do with that, either. (Before updating to Big Sur I had the antivirus software on and there was no problem). But then I tried running it from the terminal with open /Applications/Anki.app --args -b ~/myankifolder and it worked.

I’m not sure how I would specify a custom location on a Mac, and it seems that the only way to make Anki work is to run it from the terminal. Guess I’ll stick to that from now on…but thanks a lot!

Any updates on this issue, as I seem to have exactly the same problem and I can’t start Anki except from Terminal… The issue though is it won’t sync properly or show my add-ons if I use terminal!!

I wonder any solutions?