Anki 2.1.54 qt5 won't open upgrading from 2.1.49 qt5 on Windows

Anki used to open while I used 2.1.49 (qt5) but now it fails after I upgraded to 2.1.54 (qt5) (I’m running Microsoft Windows [Version 10.0.22000.856]). I have also tried deleting all my current add-ons and holding shift to run Anki to no avail. I also tried uninstalling and reinstalling everything too. Here is what pops up when I run Anki on cmd so it seems like it’s something related to the qtcore:

C:\Program Files\Anki>anki-console
Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Traceback (most recent call last):
File “”, line 1, in
File “aqt”, line 45, in
File “aqt.gui_hooks”, line 11, in
File “aqt.hooks_gen”, line 18, in
File “aqt.qt”, line 20, in
File “aqt.qt.qt5_compat”, line 15, in
ImportError: DLL load failed while importing QtCore: The specified module could not be found.
Press any key to continue . . .

I appreciate any advice, thank you!

Are you sure you are using the Qt5 version? From the error I have the impression that, on the contrary, you are using the Qt6 version.

Also, you can try to run this command before starting anki in cmd: $Env:DISABLE_QT5_COMPAT = 1.


Thank you for the help, that ended up being the case! Apparently, I actually had downloaded qt6 a long time ago and forgot. I had uninstalled Anki on this device before downloading it again as the qt5 version since I had some add-ons that required it. For anyone facing the same issue, I just did another download of the qt6 version, downgraded and quit (not sure if this was necessary), and then downloaded the qt5.