Anki 2.1.52 Release Candidate

@temlivurki

  • Could you confirm if the br issue existed in 2.1.49?
  • The copying issue is a toolkit issue that should be fixed in either a future 2.1.52rc or 2.1.53.
  • It sounds like the update to Qt 6.3 is causing issues with your system’s video driver. Switching to ‘software’ may fix the issue: Display Issues - Anki Manual

@abdo, @cyl thanks, fixed :slight_smile:

@jcznk that sounds like it might be better addressed with Reduce font size of editor toolbar/field labels? · Issue #1792 · ankitects/anki · GitHub

I confirm that the break issue is present in 2.1.49. I used six notes to test the browser search and the search and replace functions.

  • Searching for <br> returns one note, while searching for either <br /> or <br/> returns the remaining five.
  • I can successfully search for and replace both <br> and <br/>, but I can’t do the same thing for <br />.
  • The HTML view of the relevant field in all of these notes displays <br>.
  • Pressing Enter/Return in a field consistently inserts <br> (as determined by searching in the browser), but some add-ons (in this case Advanced Copy Fields) and perhaps older versions of Anki (many of my notes containing <br /> were formatted in older versions of Anki without add-ons, i.e. exclusively by pressing Enter/Return) seem to use either <br/> or <br />, which are evidently treated differently by Anki’s search and search and replace functions.

As for the potential Qt 6.3 issue, I’ll give your suggested solution a try and report back. Do you have any idea why it would only happen when using the space bar, though?

@dae Do anki had any changes on exporting decks?

I’ve exported my deck and my media files didn’t get exported too.
Only works if I export my collection.

Version ⁨2.1.52 (a989e508)⁩

Tried on rc2 too. Same result

@gustavosmen If you enabled the new import/export code as described in the changelog, then the exporting process is different. If it’s missing media files, please let me know the deck and an example media file that’s not being included, and I’ll try to reproduce the problem. If you did not enable the new code, media exports breaking would be surprising. Did you confirm the resulting .apkg is too small to contain the media files? One other possible explanation is that the media was included, but is not being imported properly.

@temlivurki

When you edit a note, the HTML gets partially normalized, eg <br /> gets converted to <br>. This is a byproduct of the way the editor works, and not a deliberate thing we try to do. Find&replace should match whatever you provide it with; I suspect the confusion here is arising from the fact that the br tags are changing as you observe them. That’s why I suggested exporting to a text file, as that allows you to observe the underlying text without risk of it changing.

Re the spacebar, it seems like it’s an issue of the screen not being redrawn at the right time by the toolkit, and maybe when you use the mouse, it ends up triggering the refresh faster. No idea why enter would behave differently though. Assuming you’re not using type-in-the-answer and not using add-ons, the two keys should take the same path.

1 Like

Nevermind. I was startled by the size of the .apkg being so small - the file was supposed to be 22mb, but only 1mb was exported. I tested it in a virtual machine just now and it all worked out. Congratulations for the good work. You deserve. It’s brilliant.

1 Like

@Rumo deserves much of the credit :slight_smile:

4 Likes

Anki 2.1.52 RC2
MacOS 12.0.1

My Anki app keeps quitting unexpectedly (and gives me the message “Anki has quit unexpectedly”. I also cannot open Anki after it quits, and my Mac doesn’t show that Anki is running at all, so I am forced to restart my computer.

I am not able to pinpoint the cause right now. I think it’s happened twice shortly after closing the Add window, but not sure. I noticed this happened with 2.1.52 RC1, so then I decided to upgrade to RC2, but now it has happened again. I will update what I find.

Edit: I removed the icon from the dock (and recents dock). I also checked the /Applications and saw that Anki.app has a Date Modified date of May 2, 2022, which I thought was weird. So I tried double-click the rc2 .dmg file and drag it into /Applications folder and hit “replace”, but then it says:

The operation can’t be completed because the item “Anki.app” is in use.

Apparently if I use Activity Monitor app and close Anki there then it actually closes and be reopened. But it doesn’t show on the Force Quit option on Mac.

I’ve verified that the breaks don’t change unless I manually overwrite them. For example, in the cases where the field represents the break as <br />, it only changes to <br> if I delete the empty line and recreate it with the Enter/Return key. Just opening the note in the browser doesn’t appear to normalise these breaks.

As for exporting the relevant notes to a plain text file, I’m still not sure what I’m meant to be looking for, since the the breaks are converted to whitespace. Could you point me in the right direction?

2.1.52rc3 is now available:

https://betas.ankiweb.net/anki2.1.52.html#release-candidate-3

@blackace72 have you tried updating to the latest macOS?

@temlivurki If you export a text file with HTML included, the HTML is exactly how it is represented inside the fields, without any transformations that might occur when viewing the card in the browse screen. Looking at the text there will show you exactly what text you need to use in find&replace.

3 Likes

I can’t see the new RC3 in beta downloads.

1 Like

Thanks for the report, should be fixed now.

Would it be possible to add an option to keep flags when exporting even if scheduling is excluded? I found it really useful in a lot of situations in which i didn’t want to share my already studied cards but i still wanted to associate certain cards with flags to indicate certain things.

I’m not sure it’s a good idea, as flags mean different things to different people. Tagging the notes would be a better way to mark them in a way that can be understood by all.

I saw this post on Reddit and have the same question - is there a way to make it so the minimized images are a certain size? In many instances I prefer to have my images maximized or I want them very very small, etc. The old addons that did this used to have an option to toggle shrinking on and to choose what size it shrunk to.

1 Like

I already use tags, but unfortunately there is no way to tag a specific card inside a note (while you can do that with a flag). Also, you can just state what flags stand for when you share the deck with other people (i’ve been doing this for a couple of years)

Mind elaborating on what you’re using them for?

I’m seeing a problem that looks a lot like what @blackace72 reported. Anki 2.1.52 RC3 has unexpectedly crashed on me several times, not giving the usual Anki crash report window, but instead this Mac window:

I’ve not yet been able to identify a pattern to when it happens. I’m using the most recent version of MacOS. After the crash, the Anki process still lingers and Anki won’t reopen, until I force-kill the process with Activity Monitor or similar.

1 Like

The crash just happened again. This time I was running Anki from terminal. If it’s any help, here’s what the terminal showed after the crash:

2.1.52rc3 has been released as stable today without further changes. If you encounter any issues with the stable release that have not already been mentioned here, please report them in a new thread.

@pinnerup that looks like a crash in the web toolkit. Maybe we’ll get lucky and the issue will be addressed in Qt 6.3.1.

1 Like