Adding Media files to a Note

Creating notes and adding media (recorded sound files), I use the “paper clip” and select the sound file. When I do this, nothing is visibly shown as having been added to the note field. To be able to see that a sound file has been attached to the note I need to toggle the markup tag, or switch out and back in to the application. Only then does it make the attached media file visible.

What’s more, if I do not make the media visible, Anki will not let me add the note. It complains that the field is empty.

I’m not able to reproduce this. Do you have any add-ons installed? If so, does disabling them help?

I do not have any add-ons installed. Not sure if this helps, but here a screen shot (video) of the behavior

Thanks @phspaelti. The issue appears to have existed since at least 2.1.50, and can be avoided by using the Qt6 version.

@kleinerpirat the video shows another issue - field focus/outline appears to be broken in older Chromium versions - you can reproduce with ./tools/run-qt5.14/15

1 Like

Thank you. I was unsure which version to try (My desktop is an Intel machine). I’ll give Qt6 a try.

Webviews don’t load on Qt5 for me - I couldn’t test this.

But Add back thick field focus border by kleinerpirat · Pull Request #2160 · ankitects/anki · GitHub will probably fix the issue, as I switched from the pseudo element approach to a much simpler trick with outline.

Could your Qt5 issue be this one? Blank Main Window - Anki Manual

Ah yes, setting --no-sandbox as an env var instead of command line argument solved the blank webview issue for me.

The field focus outline works, altough it isn’t rounded like it is on Qt6 - but that’s minor. Add-on buttons are broken though: image

Edit: Found the cause: The inset shorthand property for top, right, bottom, left isn’t supported on Qt5’s web engine. image

I’ll check if there are other differences too.

Ah, we’ve been stung by insets before too: Tag input hidden on Qt5 build · Issue #1768 · ankitects/anki · GitHub