Unable to Voice Record using Anki

Using the 23.12.1-1 anki-bin AUR package with lame installed, I’m unable to record myself using the Record Audio button in Anki on Arch Linux.

I’ve tried:

  • using a different microphone
  • unplugging and plugging back in while the application is open or before opening it
  • checking media and database
  • changing my video driver from OpenGL to Vulkan under Preferences
  • reinstalling anki-bin (using yay -Rncs anki-bin and yay -Syu anki-bin)
  • reinstalling the lame dependency (using yay -Syu lame)
  • building Anki myself using the anki AUR package
  • using the install script provided on the Anki homepage
  • installing Anki version 23.10.1
  • making sure I use the proper input device in my Sound settings
  • recording from a different application (works on Obsidian in .webm format)
  • removing all add-ons (I only had one for Markdown and KaTex Support)
  • removing the ~/.local/share/Anki2 folder
  • looking for people having similar issues online
  • restarting my PC in between some of the attempts

None of these helped, though. There is no error message, anki.log is empty. I had it working without any issues before on a previous version of Anki (might’ve been 23.10, though I’m not entirely sure), but that doesn’t seem to work anymore either. I can play existing recordings just fine, and I can even record elsewhere and put it in the media folder manually to reference and play it, but it’s all less convenient than recording within Anki.

Would be great to hear if you have any other ideas as to why I’m having this issue or could offer any help! Thanks!

Software Information:
Firmware Version: 2214
OS Name: Arch Linux
OS Build: rolling
OS Type: 64-bit
GNOME Version: 45.3
Windowing System: X11
Kernel Version: Linux 6.7.2-arch1-1

Hardware Information:
Motherboard: Asus TUF Gaming B650-Plus Wifi
Processor: AMD Ryzen 9 7950X3D
Graphics: Nvidia RTX 3060 Ti, though Anki runs on the built-in AMD Radeon Graphics

Try the compiled package AUR (en) - anki, both are unofficial builds maintained by a third party, any problems you face with these packages need to be reported to the package maintainer

Compiled builds of Anki are available on https://apps.ankiweb.net. Most of the necessary libraries are included, and Anki has been tested to work with these library versions. If you’re experiencing issues with your distro’s version, the first thing you should try is switching to the latest packaged version we provide.

You are welcome to continue using your distro’s version of Anki if you prefer, but if you run into any issues, you will need to report them to your distribution’s package maintainers.
Linux Distro Packages - Anki Manual

Thanks for the reply and help! Using the Qt5 version on the Homepage, I was actually able to record myself normally. I also double-checked and found that the Qt6 version on the homepage still doesn’t let me record properly, even though a packaged Qt6 version worked before. I guess this fixes it for me, though I would be curious to know what causes it to not work with Qt6 and if there’s anything that can be done about that.

Anki uses Qt’s audio recording facilities, so perhaps Qt6 has changed something. Aside from checking your mixer settings to make sure the recording channel is not muted, I’m afraid I don’t have any suggestions for you.