Qt: Could not load

The error:

What I did:

export QT_DEBUG_PLUGINS=1 (saw this in one post, but didn’t work)
sudo make uninstall
sudo make install

My system:

  • Xubuntu 20.04 focal
  • Anki 2.1.24 (I need that version because the addons that I use work completely fine just in that version)
1 Like

I should run “ldd” in which directory? (following the steps from here)

Try running ldd on the third libqxcb.so file (the one in the Downloads directory).

Did you install the xinerama file mentioned on the Anki download page?

That “xinerama” thing is already installed in my system.

I tried that.

Since that “anki-2.1.24-linux-amd64” folder in my Downloads folder was used to compile and install anki, should I delete it?

I tried running the following:
sudo apt install libQt5XcbQpa
sudo apt install libQt5Gui
sudo apt install libQt5DBus
sudo apt install libQt5Core
sudo apt install libxkbcommon-x11

But none of those packages were found.

PS: I used the locate command for each of libraries that weren’t found and that is the result

Guys, after some deep researches, I found the solution.

If you are having trouble with the same problem, just execute this command (yeah, just that command is enough):

sudo apt install libxkbcommon-x11-0

After that my anki started working.