Error when Custom Study

I tried to disable many different add-ons,
I am unable to custom study Anking deck anymore and unsure why…

I have deleted all filtered and custom study decks. I tried to disable some add-ons but can’t figure out the issue.

Also want to add, the error persists even when disabling all add-ons

Second Error (with all add-ons disabled)

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.40 (cf446733) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2022-08-28 18:59:42

Caught exception:
Traceback (most recent call last):
File “aqt/”, line 193, in accept
File “anki/”, line 1080, in rebuild_filtered_deck
File “anki/”, line 171, in rebuild_filtered_deck
File “anki/”, line 256, in _run_command
anki.rsbackend.DBError: DBError { info: “SqliteFailure(Error { code: Unknown, extended_code: 1 }, Some("Expression tree is too large (maximum depth 1000)"))”, kind: Other }

Related: Custom study not working?

1 Like

Newer Anki versions will prevent you from excluding more than 100 tags to avoid this issue.