Cursor/Mouse Pointer disappears while reviewing or editing

When reviewing cards on anki, when I point to the text anywhere on the reviewer or editor screen, the cursor/pointer disappears transiently or sometimes for a longer duration.
I tried disabling all addons but the problem still persisted.
This happens very frequently but not always when I start Anki on my computer - about 8 times out of 10.
I thought it might be because of the Amboss addon because it underlines text and shows pop-up definitions, so I disabled it and checked, but it didn’t help. Also, it couldn’t be that addon because the same issue also occurs in the editor window, where the addon has no function.
I checked the browser window and this issue doesn’t seem to be occuring there.
I think this is a bug in the anki desktop version ⁨23.12.1 (1a1d4d54)⁩ which I am using (latest).

Here is the debug info:
Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.6.1 PyQt 6.6.1
Platform: Windows-10-10.0.22631

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
AJT Flexible Grading [‘1715096333’, 2023-11-03T07:57, ‘None’, mod]
AMBOSS Official Medical School Step Shelf Study Resource [‘1044112126’, 2999-01-01T05:30, ‘None’, mod]
Adjust Sound Volume [‘2123044452’, 2023-12-25T19:30, ‘None’, mod]
Advanced Browser [‘874215009’, 2023-10-21T20:04, ‘None’, ‘’]
AnKing Note Types Easy Customization [‘952691989’, 2024-01-20T02:47, ‘None’, mod]
Batch Editing [‘291119185’, 2023-10-26T06:08, ‘None’, ‘’]
BetterSearch [‘1052724801’, 2023-06-16T02:14, ‘None’, ‘’]
Clickable Tags v20 original [‘380714095’, 2022-01-31T04:28, ‘None’, ‘’]
Closet For Anki [‘272311064’, 2022-08-12T13:57, ‘None’, ‘’]
Color Confirmation [‘1084228676’, 2024-01-06T15:25, ‘None’, mod]
Contanki - Controller Support for Anki beta [‘1898790263’, 2024-01-31T08:20, ‘v0.11.5-beta’, mod]
Countdown To Events and Exams [‘1143540799’, 2022-06-27T17:20, ‘None’, ‘’]
Custom Background Image and Gear Icon [‘1210908941’, 2023-04-19T06:49, ‘None’, mod]
Edit Field During Review Cloze [‘385888438’, 2024-01-03T12:49, ‘6.18’, mod]
Exam Notifier [‘236593452’, 2023-01-19T22:42, ‘None’, ‘’]
Field AutoComplete [‘511710206’, 2023-02-26T05:57, ‘None’, mod]
Hint Hotkeys [‘1844908621’, 2023-04-14T19:43, ‘None’, ‘’]
Image Occlusion Enhanced for Anki 21 [‘1374772155’, 2022-04-09T12:45, ‘None’, ‘’]
More Decks Stats and Time Left [‘1556734708’, 2023-09-24T19:38, ‘None’, ‘’]
Review Heatmap [‘1771074083’, 2022-06-30T07:13, ‘None’, ‘’]
See Previous Card Ratings in Reviewer [‘1906641654’, 2021-08-20T03:02, ‘None’, ‘’]
Speed Focus Mode auto-alert auto-reveal auto-answer [‘1046608507’, 2022-12-16T16:54, ‘None’, ‘’]

===IDs of active AnkiWeb add-ons===
1044112126 1046608507 1052724801 1084228676 1143540799 1210908941 1374772155 1556734708 1715096333 1771074083 1844908621 1898790263 1906641654 2123044452 236593452 272311064 291119185 380714095 385888438 511710206 874215009 952691989

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Customize Keyboard Shortcuts [‘24411424’, 2023-11-01T14:47, ‘None’, mod]

Did you disable them manually one-by-one, or did you “shift”-start to disable all of them at once? If it’s not obvious, “shift”-start is what I’d like to see you try. Along with anything else on the Troubleshooting checklist that you haven’t tried yet. Troubleshooting - Anki Manual

This could be an Anki bug – but since isn’t not affecting everyone with Windows 10 and updated Anki – let’s eliminate everything in your setup first.

1 Like

Thanks for the reply

I disabled all add-ons using the Shift-start method but the bug still persisted.

Also, I don’t know why the debug info shows Windows 10, because I actually have Windows 11 on my laptop.

1 Like

:eyes: Well hey now! That’s intriguing – on your laptop, what to do you see at [Windows] Settings > System > About > Windows specifications? See dae’s response below. :sweat_smile:

1 Like

Python 3.9 probably isn’t aware of Windows 11. It may get fixed in a future upgrade.

@abdo do you see this on your Windows machine?


Never had this issue. I’m on Windows 10 version 22H2 though. Build number: Windows-10-10.0.19045.

Maybe it’s a video driver issue? Can you try changing the video driver from the preferences as explained in the troubleshooting page?


Thanks for the reply!

I never had this issue when I used anki on my older, outdated laptop with windows 10. Its happening only on this new laptop since the beginning. I recently bought this new laptop with windows 11 and copy pasted the entire addon folder from the previous laptop.

I tried changing the video driver from preferences from direct3D to software, vulkan, and openGL. But it was a terrible experience using anki. Only the ‘software’ option worked but it was super laggy and terrible looking compared to the direct3D. But the issue of cursor disappearing was gone. But the overall experience was not worth using so I changed back to direct3D.

The issue still persists.


Also I wonder why is the issue happening inconsistently, like 8 out of 10 times I restart anki.
This makes me keeping restarting anki until the issue is gone (rather than accepting it as it is, lol…)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.