Copycat Importer (AnkiApp/AnkiPro)

Hi mine is doing the same. How can we overcome this pls?

Hi how do you ‘let the programme run’? I have downloaded the anki app and downloaded all the decks from AnkiApp but the top option is remaining blank? And when I go onto applications to select AnkiApp it is all greyed out so I cannot select it? Thanks

@Armiti @lara1234 Try using the “Data folder” option instead if you’re not doing so already. If that still doesn’t help, please upload the files you’re trying to import and post the links https://gofile.io

Hi Abdo. So i’ve been getting a lot of trouble after downloading the zip files from ankiapp to anki web. So I have the downloaded versions of ankiapp (copycat) and ankiweb on by computer and i’ve been trying to download my flashcards onto anki web by using the copycat add on. When I click the add on and I open my zip file and press import, all the cards are imported but they are showing up blank; " The front of this card is blank. [More information]"
What do I do…? ;(

Please see my previous reply.

Hi Yes ive tried all the different options on the ‘Add-on’ and they all arent working. I think the zip method is most likely to work but at the moment all the decks are blank when I go to review them on the actual Anki. I will upload them on that link now. I rlly appreciate your help!!! Thank you!!!

Looks like they changed the XML structure a bit. I’ll look into updating the add-on (hopefully next week).

2 Likes

Thank you so much! That would be amazing! I really appreciate your help with this :slight_smile:

This ended up working thanks for the support and for all you do for the community.

Hey!! I’m so sorry to be such a pain, but im a literal grandma when it comes to technology, and so far I’ve downloaded the tool on anki as well as all my decks on AnkiApp, but after I click here I get really confused what to do next (see below) im so sorry for being dumb with computers, but I have super important exams soon and thousands of cards that I made before I realised you had to pay (like many a victim of AnkiApp here) so if anyone could take me through the steps in a bit more detail id really appreciate it!!! Sofia :)) {
when this comes up I get lost! “importer_options”: {
“ankiapp”: {
“remote_media”: true
},
“ankipro”: {
“token”: “”
}
}
}

Hiya, thanks for your work! I’m experiencing this error message upon attempting to import to Anki from AnkiPro

@sofia.98 You don’t have to access the config.

Go to Tools > Copycat Importer > Import from AnkiApp. If you have AnkiApp installed, you should see something in the Data folder field. If so you can simply click Import to import your cards. Let me know if that’s not the case for you.

@chlxek Make sure the AnkiPro import screen is saying “logged in” in green. If it’s still saying “not logged in” despite logging in from that screen, try the following solution:

Thanks for the reply! I’ve copied the AnkiProToken value into the Config page and restarted Anki, but importing still does not work.


Also, I am logged in. However when I click the ‘open ankipronet to login’ button, a weird YouTube video shows up lol. could that be why? Thxxxx

Hey! Thank you so much for your quick reply, there was something in the data folder and i clicked import but then it said “unable to locate database file in data folder.” What do i need to do next? Thank youuu, Sofia :slight_smile:

Can you post a screenshot?

Try the “XML zips” option instead (instructions in the add-on page). If that doesn’t work, please send me the folder shown in the “data folder” field and I’ll take a look: https://gofile.io/

Super confused ahah

Hi, im trying to copy my cards from AnkiApp to normal Anki, but all the cards are blank

When i try the data folder method, i get: “Unable to locate database file in data folder.”
So i exported all my decks as .zips and tried importing using xml, but now all of the cards are blank

Would really appreciate the help as my med school exams are in 3 weeks and i dont want to have to pay to be able to review the cards on ankiapp :frowning:

That’s funny. Not sure what’s going on here. It looks like a prank or virus. Do you have other issues on your computer?

Something changed in AnkiApp recently, which broke the XML method. I’ll look into a fix soon (1-2 weeks).

1 Like

I’m in the same boat. I see the same confusing YouTube video when I try to log in to Anki Pro to transfer my cards.

1 Like