Can't drag and drop multiple tag groups, crashes Anki

A fatal error occurred, and Anki must close. Please report this message on the forums.
Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: macOS-13.4-x86_64-i386-64bit
Flags: frz=True ao=True sv=?
Add-ons, last update check: 2023-07-01 13:50:37
Add-ons possibly involved: ⁨AnkiHub⁩

Error in sys.excepthook:
Traceback (most recent call last):
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/”, line 124, in excepthook
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/”, line 137, in _maybe_report_exception_and_show_feedback_dialog
sentry_event_id = report_exception_and_upload_logs(exception=exception)
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/”, line 68, in report_exception_and_upload_logs
sentry_id = _report_exception(
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/”, line 305, in _report_exception
scope.set_context(“user files”, _user_files_context_dict())
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/”, line 365, in _user_files_context_dict
“Is ankihub database attached to anki database?”: is_ankihub_db_attached_to_anki_db(),
File “/Users/Nick/Library/Application Support/Anki2/addons21/1322529746/db/”, line 77, in is_ankihub_db_attached_to_anki_db
name for _, name, _ in“PRAGMA database_list”)
File “anki.dbproxy”, line 67, in all
File “anki.dbproxy”, line 61, in _query
File “anki._backend”, line 92, in db_query
File “anki._backend”, line 111, in _db_command
pyo3_runtime.PanicException: called Result::unwrap() on an Err value: PoisonError { … }

Original exception was:
Traceback (most recent call last):
File “aqt.taskman”, line 122, in _on_closures_pending
File “aqt.taskman”, line 71, in
File “aqt.taskman”, line 90, in wrapped_done
File “aqt.operations”, line 120, in wrapped_done
File “concurrent.futures._base”, line 439, in result
File “concurrent.futures._base”, line 391, in __get_result
File “concurrent.futures.thread”, line 58, in run
File “aqt.operations”, line 105, in wrapped_op
File “aqt.operations.tag”, line 81, in
File “anki.tags”, line 105, in reparent
File “anki._backend_generated”, line 1456, in reparent_tags
File “anki._backend”, line 150, in _run_command
pyo3_runtime.PanicException: called Option::unwrap() on a None value

I assume this only occurs with some tags as I can’t reproduce it after some brief testing. What are the tags causing this?

I was trying to drag these highlighted tags under the !OME tag. I was able to do them one at a time eventually, but I did get the error once even when doing it one at a time. There aren’t any special characters under any of those subtags


It would make things easier for us if you can provide a sample .apkg and the minimum specific tags necessary to reproduce the problem.

I couldn’t provide the entire file initially because it was a file I was commissioned to put together for someone else. I wasn’t able to get it to work with just a few and I just reset everything and tried it again and now I can’t replicate the issue. I am in a new profile so perhaps there was something wrong with the other one? I’ve tried a few different things and the error isn’t popping up any more so maybe we don’t need to worry about it?

If you find it crops up again and can reproduce it, please let us know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.