Building Anki for aarch64 from Source - Problems

Hello all!

Platform: Raspberry Pi 5
OS:Ubuntu 23.10
Memory: 8gb

Currently working at building Anki from source for aarch64 for my RPi5. Running into a few issues.

Process:

  1. Have cloned and followed the guide here
  2. Have installed PyQt6 and PyQt5 via pip install
  3. Upon clicking ./run I get the below error
> Traceback (most recent call last):
>   File "/home/user/ankidev/qt/tools/build_ui.py", line 94, in <module>
>     stock = compile(entry.ui_file)
>   File "/home/user/ankidev/qt/tools/build_ui.py", line 24, in compile
>     compileUi(f, buf)
>   File "/usr/lib/python3/dist-packages/PyQt6/uic/compile_ui.py", line 158, in compileUi
>     from PyQt6.QtCore import PYQT_VERSION_STR
> ModuleNotFoundError: No module named 'PyQt6.sip'
> Failed with code Some(1): /home/user/ankidev/out/pyenv/bin/python qt/tools/build_ui.py /home/user/ankidev/out/qt/_aqt/forms/about_qt5.py
> ninja: build stopped: subcommand failed.
> 
> Build failed.

Not sure where best to go from here, have been troubleshooting with various fixes here and here

You may not have installed the qt6 sip package

Should be installed I think. I ran:

sudo apt install python3-pip python3-venv pyqt6-dev-tools python3-pyqt6*

prior to ./run, and exported the environment variables also. For some reason, it isn’t seeing it.

Unrelated but @dae, is it possible to turn off the automatic closing of topics after a month? Every time I run into this it’s usually me wanting to provide some context that will help someone figure out an issue in the future, and I’m unable to because the thread is too old.

1 Like

The majority of posts are ephemeral, and I’m not sure allowing posts months later is a good thing in the majority of cases - it notifies all the previous participants including the OP, even though they’ve probably moved on already.

@Consonata so python3-pyqt6.sip is installed? Did you set PYTHONPATH/etc as described in linux.md?