Anki window not displaying anything

I’m using Anki 2.1.49, from the GitHub releases. When I open the binary, I am presented with a blank window, rather than the expected deck selection screen:

It looks like my profile has been loaded (from the title bar) and the menu bar is still intact, with the functionality contained within still working - for instance, I can still access the preferences:

I’ve tried a reinstall (i.e. downloading the package again), toggling the ANKI_WAYLAND environment variable and changing the video driver from OpenGL to software and back. I’m launching from the command line and there are no warnings or errors being produced.

This all seemingly started after a software update: I’m using Arch Linux, and pacman updated a number of packages included Linux itself, and some of the qt5 packages. I’ve tried downgrading the qt5 packages, but the problem persists, so not sure how relevant this might be.

If anyone has any idea what’s going on, I would be very appreciative - cheers!

1 Like

Please make sure you don’t have a distro-provided version of Anki installed as well. You could try running the binary from a terminal to see if it prints anything that identifies the issue. You could also try the latest qt6 and qt5 beta builds to see if they help:

Anki on Linux is such a mess. Thanks to their newest build stuff it’s either hopelessly outdated or is just outright getting dropped from the official repos from several distros leading to issues like these.

I updated my Arch and am facing the same problem. I had a bunch of updates, tried to revert all the ones that looked related, e.g. qt5, chromium and python stuff but to no avail. That’s with the regular Anki from the AUR as well as with the latest Anki-binary-bundle.

Fortunately, the workaround in another thread (lmao why can’t we do internal links?) still works: anki --no-sandbox

Well, it’s not like there wasn’t an option to just install the official package: Install & Upgrade - Anki Manual

I’m a bit confused by Linux users boycotting anything that isn’t available on a package manager. Surprisingly, Mac or Windows users don’t seem to get so worked up about installing software manually :smiley:

Good question! New users are prohibited from posting links, but prohibiting external links is weird. Seems the Discourse devs were lazy there ^^

I’m neither getting worked up nor am I boycotting installing software from outside the package manager. Anki wouldn’t be available on a package manager on Arch anyway because it was dropped from the official repos due to Bazel.
I have Anki and Anki binary bundle installed through the AUR which essentially just pull the latest respective versions from the Anki website.

Edit: just realized I don’t have the binary bundle installed through the AUR. It’s just the zip downloaded from the official website.

Though it’s probably partly an upstream issue too. Some stuff updated that just doesn’t work with the old Anki code anymore or something like that, I’m no expert.

That’s not the fault of Discourse. It’s the Anki forum admins that disabled links.

Sorry, this wasn’t directed at you, more the Linux userbase in general. You’re right, it’s a mess currently, but to a large extent because many people are unaware that Anki should be downloaded and installed manually.

@dae what’s your opinion on this?

@dae, so definitely don’t have a distro-provided version of Anki installed. I’m running the binary from a terminal, freshly unzipped, and I am just getting the output I usually get, namely:

Wayland support is disabled by default due to bugs.
You can force it on with an env var: ANKI_WAYLAND=1
Qt info: Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway. 
mpv not found, reverting to mplayer

Downloading the two betas (anki-2.1.50+beta3_95dbf30f), I get the same issue with the qt5 version, but the qt6 version works. The workaround given by @cellular, anki --no-sandbox also works, but I feel uneasy using an undocumented option.

Finally, I didn’t mention this before, but I’m getting the same behaviour on two different machines.

Words of warning: this has nothing to do with the OP question, but is still vaguely relevant to the discussion.

  1. Installing from a package manager is more secure than downloading stuff from yet-to-be trusted sources (btw this is probably #1 source of malware installation on windows).
  2. Installing from a package manager is about 10^10 faster and easier than manually installing stuff.
  3. Package managers handle updates automatically, and relieve either users or developers from building and/or bundling an update system.
  4. Package manager ensure (to some extent) reproducibility (at least, better than a straight install)
  5. Package manager make it easy to assert, at any moment, which programs are installed, which version, with which dependency, etc.
  6. Package manager ensure (to some extent, again) coherence between the different software installed, ie. they try to make sure the different softwares you have installed do properly work together (some package manager do not really do this, some go very far…)
  7. Package manager are free and try to bring free software (when possible) as dependencies of what you install.
  8. Package managers make it easy to debug an installation process that went wrong, since that installation step is the same for every package.

For these reasons (non exhaustive list), when a Linux user sees the application they want to install in already packaged, they don’t think twice before installing it with a package manager, instead of installing it manually.

Also, I think some Linux users do not really like the idea of having to install directly binaries, and prefer instead building on their own system. However, building Anki has proven to be quite difficult since 2.1.35 (I have yet to find a Linux distribution that has achieved packaging properly the latest Anki version, that is, achieving to build it without dirty hacks). Some distribution even disallow (by default) packaging software from binaries (unless it’s some kind of proprietary firmware and that no open-source alternative exists, or these kind of softwares).
Finally, on some distributions you simply cannot straightly run pre-built binaries (this is the case of the distribution I personally use, for instance). By luck, my package manager has packaged latest Anki (the binaries, not built from source), but not the betas for example so I cannot try them :cry:.


So it looks like it’s the latest glibc version that causes this issue as reported here

Also seems like links are working now. Might have been a trust level restriction, I guess.

1 Like

I had to disable links for new users as it was a spammer magnet. Spammers were posting innocuous-looking comments with a link hidden in them, and the multiple messages each day were a pain to deal with.

Yep, sounds like Arch has recently bumped the glibc version. glibc broke Chromium, and Qt have integrated the workaround in Qt 6.2: