Anki issue when clicking in preferences and no video


Anki snap package in Ubuntu 22.04 shows the following error when I click in preferences, new fresh install. Without addons, decks or anything.

An error occurred. Please use Tools > Check Database to see if that fixes the problem. 
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.

Anki 2.1.15 (442df9d6) Python 3.10.4 Qt 5.15.3 PyQt 5.15.6
Platform: Linux
Flags: frz=False ao=False sv=1

Caught exception:
  File "/usr/share/anki/aqt/", line 882, in onPrefs"Preferences", self)
  File "/usr/share/anki/aqt/", line 82, in open
    instance = creator(*args)
  File "/usr/share/anki/aqt/", line 25, in __init__
  File "/usr/share/anki/aqt/", line 80, in setupCollection
<class 'TypeError'>: setValue(self, int): argument 1 has unexpected type 'float'

Another problem is when I add deck with video and audio. It only works the audio. No video. I don’t know if could be related with previous error.

When I run mpv in the terminal works well although mention this:

❯ mpv outputfile.mp4 
[lavf] Using subtitle charset: ISO-8859-1
 (+) Video --vid=1 (*) (h264 1280x720 23.976fps)
 (+) Audio --aid=1 --alang=eng (*) (aac 2ch 48000Hz)
 (+) Subs  --sid=1 '' (subrip) (external)
File tags:
 Comment: outputcomment
 Title: outputtitle
libEGL warning: DRI2: failed to authenticate
[vo/gpu/opengl] Suspected software renderer or indirect context.
[vo/gpu] VT_GETMODE failed: Inappropriate ioctl for device
[vo/gpu/opengl] Failed to set up VT switcher. Terminal switching will be unavailable.
[vo/gpu] Failed to commit ModeSetting atomic request (-13)
[vo/gpu/opengl] Failed to set CRTC for connector 77: Permission denied
[vo/gpu/vulkan/libplacebo] Found no suitable device, giving up.
[vo/gpu/vulkan/libplacebo] Failed initializing vulkan device
Failed to open VDPAU backend cannot open shared object file: No such file or directory
[vo/vdpau] Error when calling vdp_device_create_x11: 1
[vo/xv] No Xvideo support found.
[vo/sdl] Using opengl
[vo/sdl] Warning: this legacy VO has bad performance. Consider fixing your graphics drivers, or not forcing the sdl VO.
AO: [pulse] 48000Hz stereo 2ch float
VO: [sdl] 1280x720 yuv420p
AV: 00:00:02 / 01:03:06 (0%) A-V:  0.000

I have tried changing between wayland and X11 and it’s the same.

I’d be grateful if someone could help me.

TL;DR snap has two anki packages, one of which is severely outdated. It’s the one you downloaded. Please install anki-ppd instead.

Yes I was using another version, the deb package version. I have removed it and I’ve reconfigured my note types and all problems are solved.

Thank you very much