Anki Bug issue on a mac computer any time I try to start reviewing my decks.I have tried everything I can think of so please help!

Hello, I have been using anki for a bit but I would still consider myself someone who is very basic with its usage. I am running anki on a mac computer. Unfortunately, I have begun having an issue whenever I try to start doing my deck for the day. After clicking “study now” an error message pops up (“Anki encountered a problem. Please follow the trouble shooting steps. Add-ons possibly involved”) or it won’t allow me to move on from the first card. I have tried using a small sub deck. I have removed all of my add ons. I have restarted anki and my computer several times. I have clicked on browes and checked the window size. I have uninstalled anki and downloaded a new anki. All have resulted in error messages currently making anki essentially unuseable for me. I have been able to make new cards on it (go figure). Any advice on how to fix this would be greatly appreciated. I have attached the error code below if this helps any. (I did take out my name in the error code for safety purposes)

Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.0-x86_64-i386-64bit

Traceback (most recent call last):
File “aqt.webview”, line 50, in cmd
File “aqt.webview”, line 157, in _onCmd
File “aqt.webview”, line 680, in _onBridgeCmd
File “_aqt.hooks”, line 5415, in call
File “/Users/-----------/Library/Application Support/Anki2/addons21/1508357010/utils/JSCallable.py”, line 29, in _onBridgeMessage
ret = func(*argList)
File “/Users/------/Library/Application Support/Anki2/addons21/1508357010/jsapi/remainingCardCount.py”, line 10, in getCurrentRemainingCardCount
if reviewer.hadCardQueue:
AttributeError: ‘Reviewer’ object has no attribute ‘hadCardQueue’

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Custom Background Image and Gear Icon ['anki_background ', 2023-04-18T20:19, ‘None’, mod]
Remaining time for Anki 21 [‘1508357010’, 2020-12-13T08:14, ‘20.12.13i151’, ‘’]

===IDs of active AnkiWeb add-ons===
1508357010

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

Remaining time for Anki 21 is the culprit here, which has known issues with current Anki versions. There seems to be a bugfix: Erro in Anki 23.10beta6 · Issue #78 · trgkanki/remaining_time · GitHub, otherwise you should deactivate it.

2 Likes

Thank you so much!